0

I use the book document class and I have margins set like this:

\usepackage[top = 1.2cm, bottom = 1.2cm, left = 2cm, right = 1cm]{geometry}

But the left and right margin switch depending on that is the page number even or odd. For example, on the page 1 the left margin is 2cm and the right margin is 1cm, on the page 2 the left margin is 1cm and the right margin is 2cm. How can I disable this, so that on the all pages the left margin is 2cm and the right margin is 1cm?

  • 2
    Use the oneside option for the document class (\documentclass[oneside]{book}). – Phelype Oleinik May 21 '18 at 15:48
  • Try to pass the option oneside to the book class, it should prevent this behaviour from happening. – RockyRock May 21 '18 at 15:49
  • But do you intend to print one-sided? – Bernard May 21 '18 at 17:28
  • @Bernard No, I don't. I just wanted to know how to do it. It may come in handy one day. – Hanlon May 22 '18 at 10:26
2

The oneside option for the book class allows you to do what you want:

\documentclass[12pt, oneside]{book}
\usepackage[top = 1.2cm, bottom = 1.2cm, left = 2cm, right = 1cm]{geometry}
\usepackage{blindtext}

\begin{document}

\chapter{1}
\blindtext[5]
\chapter{2}
\blindtext[5]
\chapter{3}
\blindtext[5]

\end{document}

Romain

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.