0

My problem is that the number of pages not appear in the pdf file. I used winEdt 10. I used the following thesis LATEX template

\documentclass[12pt,b5paper,openright]{report}
%\usepackage{hyperref}
\usepackage{epsfig}
\usepackage{color}
\usepackage{latexsym}
\usepackage{graphicx}
%\usepackage{subfigure}
\usepackage{wrapfig}
\usepackage{multirow}
\usepackage{amssymb,amsmath}
\usepackage{lscape}
\usepackage{amsthm}
\usepackage[mathscr]{eucal}

%\usepackage{subfigure}
%\usepackage{array}
\usepackage{fancyhdr}
%\usepackage{setspace}  %%\singlespacing   \doublespacing   \onehalfspacing
\usepackage[left=1.5cm, right=1.5cm, top=3cm, bottom=1.5cm, includefoot, headheight=11pt]{geometry}
\pagestyle{plain}
\includeonly{All/title,All/Aproval,All/Acknowledgements,All/Summary,All/ch1,All/ch2,All/ch3,All/ch4,All/ch5,All/ch6,All/References}
\usepackage[compact]{titlesec} %% TO put space after and before sections or subsections
\titlespacing{\section}{0pt}{+8mm}{+5mm}
\titlespacing{\subsection}{0pt}{+6mm}{+4mm}
\titlespacing{\subsubsection}{0pt}{+6mm}{+4mm}
\parindent=5mm
\newcommand{\h }{\hspace*{18pt}}
\newcommand{\G}{\mathscr{G}}

\begin{document}
%++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
\include{All/title}
%+++++++++++++++++++++++++++++++++++++++++++++++++
\include{All/Aproval}
%+++++++++++++++++++++++++++++++++++++++++++++++++
\include{All/Acknowledgements}
%+++++++++++++++++++++++++++++++++++++++++++++++++


\pagenumbering{roman}
\setcounter{page}{1}
\pagestyle{fancyplain}

%+++++++++++++++++++++++++++++++++++++++++++++++++

\fancyhead[RE,LO]{}
\fancyfoot[CE,CO]{\thepage}
\pagestyle{fancyplain}
%\addcontentsline{toc}{chapter}{Contents}

\tableofcontents

\include{All/Summary}
\include{All/ch1}
\include{All/ch2}
\include{All/ch3}
\include{All/ch4}
\include{All/ch5}
\include{All/ch6}
\include{All/References}
\end{document}
2

You have incorrectly set up fancyhdr.

When you compile you should notice these warnings:

Package Fancyhdr Warning: \fancyhead's `E' option without twoside option is use on input line xx.
Package Fancyhdr Warning: \fancyfoot's `E' option without twoside option is use less on input line xx.

In other words you have not used the twoside option when you've loaded the report class. So it doesn't make sense to set even and odd page headers and footers.

You probably want something like this:

\fancyhead{}
\fancyfoot[C]{\thepage}

instead of

\fancyhead[RE,LO]{}
\fancyfoot[CE,CO]{\thepage}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.