4

I tried installing LyX 2.3.0 following the instructions I found here, but I got the error message that 'The repository does not have a release file' so apt-get won't let me add it.

My other laptop is running Ubuntu 16.04 and I didn't have this problem, and it's quite annoying since I have a bunch of LyX documents written on the 2.3.0 version which can't be opened by the latest addition available in Ubuntu's repository.

  • This seems to be a general problem that I get when trying to add repositories - I tried to add the KXStudio repository for instance and no joy. – Sebastian May 22 '18 at 19:23
5

Tried on July 2018, with Ubuntu 18.04.1 LTS, and it worked without issues. I just did as per the doc:

  1. sudo add-apt-repository ppa:lyx-devel/release
  2. sudo apt-get update
  3. sudo apt-get install lyx
  • That's great it's working now. Just for reference, I think the core problem was tracked and solved with this ticket: lyx.org/trac/ticket/11166 – scottkosty Jul 28 '18 at 0:34
2

The solution that worked for me is to install the version 2.3 from a previous release (I used 17.10).

If you go to the official PPA (https://launchpad.net/~lyx-devel/+archive/ubuntu/release) you will find it. Click on "view package details" and download the packages from the release of your choice. In my case, lyx-common_2.3.0-1~artful~ppa1_all.deb and lyx_2.3.0-1~artful~ppa1_amd64.deb. I am assuming you have a 64-bit installation.

Remove your current lyx installation using sudo apt purge lyx && sudo apt autoremove. I recommend installing apt-get install texlive-generic-extra before proceeding since this package is removed when you uninstall the "old" lyx.

To proceed installing the packages you just donwloaded. sudo dpkg -i lyx-common_2.3.0-1~artful~ppa1_all.deb && sudo dpkg -i lyx_2.3.0-1~artful~ppa1_amd64.deb. It should work fine.

PS: If it complains about dependencies, do a sudo apt install -f.

  • Cheers! My solution was to install Ubuntu 16.04 since I had problems installing a bunch of other programs. – Sebastian Jul 9 '18 at 8:41
0

Exactly, the problem is incompatible file structures on LyX 18.4. Would posit a guess, that an update is coming for LyX 18.4 to 2.3.0-1, but would be really nice to just know when.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.