0

I want to cite a book (this one, in case it matters) using \citet. The book has two editors but no authors, so when compiling

According to \citet[section 4.6]{Abramowitz70}

with the elsarticle-num bibliography style (from an Elsevier journal) I get the following in the compiled .pdf file:

According to (Author?) [8, section 4.6]

  • Is there a simple solution to make the bibliography style use the editor when there are no authors?
  • Failing that, can I manually specify an author to be shown for that citation?

I prefer not to include a fake author in my .bib file to solve this, because the book's cover clearly mentions the editors and no authors.

  • 1
    Can you please prepare a short, yet complete MWE/MWEB of what you are doing? The following worked for me gist.github.com/moewew/f13734ca1b143b943791cd9b7d1369eb So it seems it should be possible in general, the question is why it does not work in your special case. – moewe May 23 '18 at 19:01
  • @moewe I’m using Elsevier’s elsarticle-num bibliography style. That must be the problem then. Thanks for testing – Luis Mendo May 23 '18 at 19:21
3

Let's assume your .bib entry looks like this

@book{AS,
  editor    = {Milton Abramowitz and Irene Stegun},
  title     = {Handbook of Mathematical Functions with Formulas, Graphs, and Mathematical Tables},
  year      = {1970},
  publisher = {Dover},
  address   = {New York},
}

As it turns out in the comments you use elsarticle-num, which produces a .bbl with the relevant part looking like

\bibitem{AS}
M.~Abramowitz, I.~Stegun (Eds.), Handbook of Mathematical Functions with
  Formulas, Graphs, and Mathematical Tables, Dover, New York, 1970.

plainnat (as style - as the name suggests - specifically designed for natbib) on the other hand produces

\bibitem[Abramowitz and Stegun(1970)]{AS}
Milton Abramowitz and Irene Stegun, editors.
\newblock \emph{Handbook of Mathematical Functions with Formulas, Graphs, and
  Mathematical Tables}.
\newblock Dover, New York, 1970.

Note the additional optional argument of \bibitem that holds the editor names and year. This optional argument is crucial to \citet working correctly. Indeed, the beginning of natbib.sty mentions

 % With standard numerical .bst files, only numerical citations are
 % possible. With an author-year .bst file, both numerical and
 % author-year citations are possible.
 %
 % If author-year citations are selected, \bibitem must have one of the
 %   following forms:
 %   \bibitem[Jones et al.(1990)]{key}...
 %   \bibitem[Jones et al.(1990)Jones, Baker, and Williams]{key}...
 %   \bibitem[Jones et al., 1990]{key}...
 %   \bibitem[\protect\citeauthoryear{Jones, Baker, and Williams}{Jones
 %       et al.}{1990}]{key}...
 %   \bibitem[\protect\citeauthoryear{Jones et al.}{1990}]{key}...
 %   \bibitem[\protect\astroncite{Jones et al.}{1990}]{key}...
 %   \bibitem[\protect\citename{Jones et al., }1990]{key}...
 %   \harvarditem[Jones et al.]{Jones, Baker, and Williams}{1990}{key}...
 %
 % This is either to be made up manually, or to be generated by an
 % appropriate .bst file with BibTeX.
 %                            Author-year mode     ||   Numerical mode
 % Then, \citet{key}  ==>>  Jones et al. (1990)    ||   Jones et al. [21]
 %       \citep{key}  ==>> (Jones et al., 1990)    ||   [21]

Note that the situation is no better even if Abramowitz and Stegun were promoted to authors. Even then you would get the complaint (Author?)

If you were to load natbib with the author-year option while using elsarticle-num, you'd even get

Package natbib Error: Bibliography not compatible with author-year citations.

So the solution here is to use a .bst style that is compatible with natbib's author-year citations.

  • Thank you so much for the great answer. I have included the information about the bibligraphy style in my question – Luis Mendo May 23 '18 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.