0

This question already has an answer here:

I installed TeXLive 2016 via PPA and used following set of commands-

sudo add-apt-repository ppa:jonathonf/texlive
sudo apt update
sudo apt install texlive-full

Due to some reasons, I tried to remove it but I couldn't. Later, I installed TeXLive from the official website by following this link Installing TeX Live over the Internet. I used the following command-

ravi@home:~/Downloads/install-tl-20180527$ sudo ./install-tl

Now, I am able to use TeXLive 2018 on Ubuntu 14.04 LTS using Texmaker 4.1 (compiled with Qt 4.8.4 and Poppler 0.24.3). However, my Ubuntu shows the following error-

enter image description here

It seems that TeXLive2016 is the culprit. I used sudo apt-get purge texlive* but it didn't work. Please see below-

The following packages have unmet dependencies:
 asymptote : Depends: texlive-latex-base but it is not going to be installed
             Depends: texlive-base-bin
             Depends: texlive-pstricks but it is not going to be installed
 dvipng : Depends: texlive-base-bin
 feynmf : Depends: texlive-latex-base but it is not going to be installed
          Depends: texlive-font-utils but it is not going to be installed
          Depends: texlive-extra-utils but it is not going to be installed
 fragmaster : Depends: texlive-base-bin
              Depends: texlive-latex-base but it is not going to be installed
              Depends: texlive-latex-recommended but it is not going to be installed
              Depends: texlive-extra-utils but it is not going to be installed
              Depends: texlive-font-utils but it is not going to be installed
 latex-beamer : Depends: texlive-latex-base but it is not going to be installed
 latex-xcolor : Depends: texlive-latex-recommended but it is not going to be installed
 latexmk : Depends: texlive-latex-base but it is not going to be installed
 pgf : Depends: texlive-latex-recommended but it is not going to be installed
 prosper : Depends: texlive-latex-base but it is not going to be installed
           Depends: texlive-pstricks but it is not going to be installed
           Depends: texlive-latex-recommended but it is not going to be installed
 purifyeps : Depends: texlive-metapost but it is not going to be installed
 tex4ht-common : Depends: texlive-base-bin
                 Recommends: tex4ht but it is not going to be installed
 tipa : Depends: texlive-latex-base but it is not going to be installed
        Depends: texlive-base-bin
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Also tried sudo apt-get autoremove and sudo apt-get -f install. Plese, see below-

ravi@home:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  luatex texlive-binaries texlive-extra-utils texlive-font-utils
  texlive-fonts-recommended texlive-fonts-recommended-doc
  texlive-generic-recommended texlive-latex-base
The following packages will be REMOVED:
  context
The following NEW packages will be installed:
  luatex texlive-binaries texlive-extra-utils texlive-font-utils
  texlive-fonts-recommended texlive-fonts-recommended-doc
  texlive-generic-recommended texlive-latex-base
0 upgraded, 8 newly installed, 1 to remove and 264 not upgraded.
1 not fully installed or removed.
Need to get 0 B/30.2 MB of archives.
After this operation, 9,608 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 295461 files and directories currently installed.)
Removing context (2016.05.17.20160523-1~ubuntu14.04.1york0) ...
unknown option: format
dpkg: error processing package context (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 context
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any workaround to fix it, please?

marked as duplicate by Stefan Pinnow, Bobyandbob, Kurt, Phelype Oleinik, Zarko May 27 '18 at 18:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.