0

I am intending to change a document to use the glossaries-extra package. When I add \usepackage{glossaries-extra} to my preamble (or rather a file loaded with \input supposed to contain the \usepackage call and the actual glossary entries) I get the following error message:

! LaTeX Error: Command \dddot already defined.
               Or name \end... illegal, see p.192 of the manual.

The last package being loaded before the error is the amsopn package.

I tried to produce the conflict in a MWE just loading a few of the candidate packages in changing order but did not yet manage to reproduce it yet. Grepping for dddot through the directories containing the style files of the glossaries family produced no results either.

I am aware of the entry in the FAQ, but it does not tell me how to find the packages actually containing the conflicting definitions.

[Edit:]

Sorry for not having provided a MWE yet, well, I simply have not managed to produce one which actually reproduces the error message, and was hoping to get some advice for the general approach to this kind of problem, which I thankfully got and will pursue. I will nevertheless now post a MWNE so to speak, for which I have collected the \usepackage and \RequirePackage from my own style file, converting the latter appropriately:

\documentclass[draft,11pt,oldfontcommands,a4paper,showtrims]{memoir}
\usepackage{verbatim}
\usepackage{fontspec}
\usepackage{pdfpages}
\setromanfont[Mapping=tex-text,Numbers=OldStyle,SmallCapsFont={* Caps}]{Latin Modern Roman}

\usepackage[rightmargin=0cm,vskip=0cm,indentfirst=false]{quoting}
\usepackage{enumitem}
\usepackage[ruled,para*]{manyfoot}

\usepackage[xindy,nonumberlist,nopostdot,toc]{glossaries-extra}
\makeglossaries

\usepackage{perpage}
\usepackage{polyglossia}
\setdefaultlanguage{english}
\setotherlanguage{sanskrit}
\setotherlanguage{german}
\setotherlanguage{french}
\newfontfamily\sanskritfont{Latin Modern Roman}[Ligatures=TeX]

\usepackage[authordate,backend=biber,indexing=true]{biblatex-chicago}
\usepackage{xpatch}
\usepackage{ltablex}
\usepackage[font=footnotesize,hangindent=3em,subindent=1.5em]{idxlayout}
\usepackage{nth}

\usepackage{marginnote}
\usepackage{xcolor}
\usepackage{xspace}
\usepackage{varioref}

Here is the list of files:

 *File List*
  memoir.cls    2018/04/04 v3.7g configurable book, report, article document cl
ass
   ifpdf.sty    2017/03/15 v3.2 Provides the ifpdf switch
  ifetex.sty    2018/03/31 v1.2a ifetex
 ifxetex.sty    2010/09/12 v0.6 Provides ifxetex conditional
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
   mem11.clo    2008/01/30 v0.3 memoir class 11pt size option
bhatt_volume.sty    
fontspec.sty    2017/11/09 v2.6g Font selection for XeLaTeX and LuaLaTeX
  xparse.sty    2018-04-30 L3 Experimental document command parser
   expl3.sty    2018-04-30 L3 programming layer (loader) 
expl3-code.tex    2018-04-30 L3 programming layer 
l3xdvipdfmx.def    
fontspec-xetex.sty    2017/11/09 v2.6g Font selection for XeLaTeX and LuaLaTeX
 fontenc.sty
   tuenc.def    2017/04/05 v2.0i Standard LaTeX file
fontspec.cfg
 perpage.sty    2014/10/25 2.0 Reset/sort counters per page
polyglossia.sty    2018/04/07 v1.43 Alternative to Babel for XeLaTeX and LuaLaT
eX
etoolbox.sty    2018/02/11 v2.5e e-TeX tools for LaTeX (JAW)
makecmds.sty    2009/09/03 v1.0a extra command making commands
 xkeyval.sty    2014/12/03 v2.7a package option processing (HA)
 xkeyval.tex    2014/12/03 v2.7a key=value parser (HA)
gloss-english.ldf    polyglossia: module for english
gloss-sanskrit.ldf    polyglossia: module for sanskrit
devanagaridigits.sty    2010/04/01 v0.1 Formatting of Devanagari digits
gloss-german.ldf    polyglossia: module for german
 babelsh.def    2013/04/30 Babel common definitions for shorthands
 Taken verbatim from babel.def (2013/04/15 v3.9e)
gloss-french.ldf    polyglossia: module for french
unicode-math.sty    2018/02/02 vv0.8l Unicode maths in XeLaTeX and LuaLaTeX
unicode-math-xetex.sty    2018/02/02 vv0.8l Unicode maths in XeLaTeX and LuaLaT
eX
l3keys2e.sty    2018-04-30 LaTeX2e option processing using LaTeX3 keys
filehook.sty    2011/10/12 v0.5d Hooks for input files
filehook-memoir.sty    2011/01/03 v0.1 filehook patch for memoir class
  fix-cm.sty    2015/01/14 v1.1t fixes to LaTeX
  ts1enc.def    2001/06/05 v3.0e (jk/car/fm) Standard LaTeX file
biblatex-chicago.sty    2018/01/10 v 3.10 biblatex style
biblatex.sty    2018/03/04 v3.11 programmable bibliographies (PK/MW)
pdftexcmds.sty    2018/01/30 v0.27 Utility functions of pdfTeX for LuaTeX (HO)
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
kvoptions.sty    2016/05/16 v3.12 Key value format for package options (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
  logreq.sty    2010/08/04 v1.0 xml request logger
  logreq.def    2010/08/04 v1.0 logreq spec v1.0
  ifthen.sty    2014/09/29 v1.1c Standard LaTeX ifthen package (DPC)
     url.sty    2013/09/16  ver 3.4  Verb mode for urls, etc.
 xstring.sty    2013/10/13  v1.7c  String manipulations (C Tellechea)
  blx-dm.def    2018/03/04 v3.11 biblatex localization (PK/MW)
blx-unicode.def
blx-compat.def    2018/03/04 v3.11 biblatex compatibility (PK/MW)
biblatex.def    2018/03/04 v3.11 biblatex compatibility (PK/MW)
chicago-authordate.bbx    2018/01/11 v 3.10 biblatex bibliography style
chicago-dates-common.cbx    2018/01/11 v 3.10 biblatex citation style
chicago-authordate.cbx    2018/01/11 v 3.10 biblatex citation style
biblatex.cfg    
  xpatch.sty    2012/10/02 v0.3 Extending etoolbox patching commands
 ltablex.sty    2014/08/13 v1.1 Modified tabularx
longtable.sty    2014/10/28 v4.11 Multi-page Table package (DPC)
idxlayout.sty    2012/03/30 v0.4d Configurable index layout
multicol.sty    2018/04/20 v1.8s multicolumn formatting (FMi)
  xspace.sty    2014/10/28 v1.13 Space after command names (DPC,MH)
varioref.sty    2016/02/16 v1.5c package for extended references (FMi)
     nth.sty    2002/02/27
marginnote.sty    2018/04/13 v1.3 non floating margin notes for LaTeX
  xcolor.sty    2016/05/11 v2.12 LaTeX color extensions (UK)
   color.cfg    2016/01/02 v1.6 sample color configuration
   xetex.def    2017/06/24 v5.0h Graphics/color driver for xetex
pdfpages.sty    2017/10/31 v0.5l Insert pages of external PDF documents (AM)
    calc.sty    2017/05/25 v4.3 Infix arithmetic (KKT,FJ)
 eso-pic.sty    2015/07/21 v2.0g eso-pic (RN)
atbegshi.sty    2016/06/09 v1.18 At begin shipout hook (HO)
graphicx.sty    2017/06/01 v1.1a Enhanced LaTeX Graphics (DPC,SPQR)
graphics.sty    2017/06/25 v1.2c Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    2016/01/03 v1.10 sin cos tan (DPC)
graphics.cfg    2016/06/04 v1.11 sample graphics configuration
 ppxetex.def    2017/10/31 v0.5l Pdfpages driver for XeTeX (AM)
 quoting.sty    2014/01/28 v0.1c Consolidated environment for displayed text
enumitem.sty    2011/09/28 v3.5.2 Customized lists
manyfoot.sty    2005/09/11 v1.10 Many Footnote Levels Package (NCC)
nccfoots.sty    2005/02/03 v1.2 NCC Footnotes Package (NCC)
padoux_gls.tex
glossaries-extra.sty    2018/04/25 v1.30 (NLCT)
glossaries.sty    2018/05/10 v4.38 (NLCT)
mfirstuc.sty    2017/11/14 v2.06 (NLCT)
textcase.sty    2004/10/07 v0.07 Text only upper/lower case changing (DPC)
    xfor.sty    2009/02/05 v1.05 (NLCT)
datatool-base.sty    2018/04/16 v2.30 (NLCT)
 amsmath.sty    2017/09/02 v2.17a AMS math features
 amstext.sty    2000/06/29 v2.01 AMS text
  amsgen.sty    1999/11/30 v2.0 generic functions
  amsbsy.sty    1999/11/29 v1.2d Bold Symbols
  amsopn.sty    2016/03/08 v2.02 operator names
  substr.sty    2009/10/20 v1.2 Handle substrings
datatool-fp.sty    2018/04/16 v2.30 (NLCT)
      fp.sty    1995/04/02
defpattern.sty    1994/10/12
fp-basic.sty    1996/05/13
fp-addons.sty    1995/03/15
 fp-snap.sty    1995/04/05
  fp-exp.sty    1995/04/03
fp-trigo.sty    1995/04/14
  fp-pas.sty    1994/08/29
fp-random.sty    1995/02/23
  fp-eqn.sty    1995/04/03
  fp-upn.sty    1996/10/21
 fp-eval.sty    1995/04/03
glossaries-compatible-307.sty    2018/05/10 v4.38 (NLCT)
tracklang.sty    2018/02/21 v1.3.5 (NLCT) Track Languages
tracklang.tex    2018/02/21 v1.3.5 (NLCT) Track Languages Generic Code
glossary-hypernav.sty    2018/05/10 v4.38 (NLCT)
glossary-list.sty    2018/05/10 v4.38 (NLCT)
glossary-long.sty    2018/05/10 v4.38 (NLCT)
glossary-super.sty    2018/05/10 v4.38 (NLCT)
supertabular.sty    2004/02/20 v4.1e the supertabular environment
glossary-tree.sty    2018/05/10 v4.38 (NLCT)
  french.lbx    2018/03/04 v3.11 biblatex localization (PK/MW)
cms-french.lbx    2018/01/09 v 3.10 biblatex localization
  german.lbx    2018/03/04 v3.11 biblatex localization (PK/MW)
cms-german.lbx    2018/01/09 v 3.10 biblatex localization
 english.lbx    2018/03/04 v3.11 biblatex localization (PK/MW)
american.lbx    2018/03/04 v3.11 biblatex localization (PK/MW)
cms-american.lbx    2018/01/09 v 3.10 biblatex localization
ragged2e.sty    2009/05/21 v2.1 ragged2e Package (MS)
everysel.sty    2011/10/28 v1.2 EverySelectfont Package (MS)
  padoux.bbl
pdflscape.sty    2016/05/14 v0.11 Display of landscape pages in PDF (HO)
  lscape.sty    2000/10/22 v3.01 Landscape Pages (DPC)
  padoux.ind
 ***********

Instead of building a MWE from scratch I will now have to, as per Skillmon's comment, "merge" my original file with my style file for this project, and the included file for the glossaries, and start commenting out stuff, until I find the cause for the error message.

Edit:

Here is a MWE:

\documentclass{article}
\usepackage[math-style = upright]{unicode-math}
\setmathfont{Latin Modern Math}
\usepackage{glossaries}
\begin{document}
Some text.
\end{document}

Changing the loading order of unicode-math and glossaries avoids the error message.

  • 13
    87 questions, 20 answers, yet you do not post a MWE :-( – Johannes_B May 28 '18 at 6:35
  • 2
    Thanks for mentioning that one of the packages being loaded is amsopn. Are you willing to share with us which other packages are loaded as well? – Mico May 28 '18 at 6:39
  • 4
    On my system (it's not a full installation) there are thirteen files that mention \dddot in the tex/latex tree and the majority of those (re)defines it. You will have to give us more than the error and an unsuccessful grep over glossaries. An MWE would be the best way to gives us these additional bits of information. You may very well find the culprit yourself when writing it up. – moewe May 28 '18 at 7:05
  • 4
    The error is easy to understand and reproduce: glossaries(-extra) loads amsmath and this complains if \dddot is already defined. But this doesn't identify the package that defines \dddot in the first place. – Ulrike Fischer May 28 '18 at 7:50
  • 3
    that is a documented feature that you should load amsmath before unicode-math if you use both. – David Carlisle May 28 '18 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.