2

I've downloaded and set up LanguageTool to connect to TeXstudio like this: TeXstudio settings

LanguageTool is starting when I start TeXstudio and, according to the icon, connected: LT is connected

Additionally, I'm able to manually perform a check using my browser. For instance by opening:

http://localhost:8081/v2/check?text=W%C3%A4hrend%20Sie%20das%20Ganze%20mir%20einem%20Holzl%C3%B6ffel%20oder%20einem%20Paar%20St%C3%A4bchen%20r%C3%BChren.&language=auto

However, these problems are not shown in the TeXstudio editor itself: enter image description here

According to Finding errors using n-gram data, LT should highlight the word "mir" here. (The issue is not related to n-grams, other problems also don't show up.)

As suggested in Problems Installing Language Tool in TexStudio, I also tried the same thing with LT-3.5, but still face the same problem. (Errors are not highlighted)

If you do not know the answer to the problem, could you suggest steps to debug? (E.g. where to find TeXstudios log files, if there are any)

  • The exact same problem still persists for me. TeXStudio (2.12.14) is connected to LanguageTool (4.4); the test link you pasted works fine in the browser. In TeXStudio, no grammar errors are shown (spelling errors are). Everything seems to work in theory. I am on en_GB, so there should be no issues with language settings that are not valid, as in your answer. Inline Check of grammar is enabled. – Hans Lollo Feb 26 at 18:12
3

As it turns out, this issue is related to the selected language, where "de_DE_frami" is not a valid option. After installing another version of the German spell checking dictionary (via sudo apt install hunspell-de-de) and selecting it in the options, LanguageTool now highlights the errors correctly.

enter image description here

  • Had to symlink ln -s /usr/share/hunspell/de_DE.dic de.dic, because LanguageTool does not know de_DE as a Language. Also symlink the .aff file. This way i got it working. – Wagner Michael Dec 21 '18 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.