0

I have some problem with my installation of Texlive Vanilla 2018 on my Debian Stretch.

Everything going well during installation but when I am trying to use Texmaker or LyX, they don't work and don't find any package.

At the end of the vanilla installation, I have tested that everything working well with :

tex --version

latex sample2e.tex

xdvi sample2e.dvi

pdflatex sample2e.tex

following this page : https://www.tug.org/texlive/doc/texlive-fr/texlive-fr.html#x1-350003.4

And I obtain the right pdf and everything was fine with this method.

So, I think that there is a problem with the equivs dummy package or with the PATH.

In LyX, all the document class are unavailable and in TeXmaker, the command: "pdflatex -synctex=1 -interaction=nonstopmode %.tex" is not working.

I already succeed to install Texlive Vanilla on my previous computer on Debian Stretch (With texlive2016 1 years ago) but it was difficult too. This time I don't see any solution. The Vanilla Texlive is my nightmares with Debian using.

Is there a particularity with the 2018 teXlive Vanilla ?

  • Welcome to TeX.SX! So you could compile the sample file but not your own code? If yes it could help to see your code, as minimal working example. – Bobyandbob May 29 '18 at 16:34
  • How exactly did you add the tl18 path? Who exactly are you starting texmaker or LyX? Command line or via a menu? – daleif May 29 '18 at 17:50
  • I can compile if I use the sample in the terminal. But I can't compile anything with teXmaker or LyX I have used : export PATH=/usr/local/texlive/2018/bin/x86_64-linux:$PATH export MANPATH=/usr/local/texlive/2018/texmf-dist/doc/man:$MANPATH export INFOPATH=/usr/local/texlive/2018/texmf-dist/doc/info:$INFOPATH I start Texmaker and Lyx via the toolbar (not sure of the english word), i am using XFCE on Debian. – blue sky May 30 '18 at 0:13
1

This is a problem of PATH setup. According to your comment you are using

export PATH=/usr/local/texlive/2018/bin/x86_64-linux:$PATH

which is fine for a terminal session, but not for the GUI you are using. If you are on Debian, you will need to do something else, there are two ways:

  • (for all users) either you set the PATH globally in /etc/profile.d/texlive.sh where you put the three export lines you mentioned
  • (only for you) add the three export lines to $HOME/.xsessionrc which is sourced

After one of these changes and re-logging in the GUI environment should have a PATH setting including the local TL, and the TeX GUIs should pick it up automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.