0

I have installed TeX Live 2018 from the .iso file, along side with my old TeX Live 2015 installed using sudo apt-get install texlive-full on Linux Mint. When compiling a XeLaTeX document that uses the STIX Two font:

% STIX Two font
\usepackage[math-style=ISO]{unicode-math}
\usepackage{xltxtra}
\setmainfont{STIX2Text}[
  Extension       = .otf,
  UprightFont     = *-Regular,
  ItalicFont      = *-Italic,
  BoldFont        = *-Bold,
  BoldItalicFont  = *-BoldItalic ]

\setmathfont{STIX2Math.otf}

I got a "font-not-found" error.

I tried copying the *.otf files to /usr/local/texlive/2018/texmf-dist/fonts/opentype/public/stix2 but the fonts is still not recognized by the new TeX Live.

Previously for TeX Live 2015, I had just to copy the above stix2 folder to /usr/share/fonts/opentype. The folder is still there but TeX Live 2018 cannot recognize it either.

Any suggestions please?

Thank you very much for your help!

  • Issue sudo cp $(kpsewhich -var-value TEXMFSYSVAR)/fonts/conf/texlive-fontconfig.conf /etc/fonts/conf.d/09-texlive.conf and then sudo fc-cache -fsv – egreg May 29 '18 at 20:32
  • @egreg Thanks, but that did not help :( – Khue May 29 '18 at 20:42
  • @egreg I removed TeX Live 2015, then opened tlmgr gui to rebuild symlinks and font maps, and it works now. – Khue Jun 2 '18 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.