0

When I run the script below with Quick Build it picks up very old versions of the .bib file chap2.bib that is long since gone

\documentclass[11pt]{book}
\usepackage{tgpagella}
\usepackage{lmodern}

\usepackage[natbibapa]{apacite}

\begin{document}

\input{chapter2}

\bibliographystyle{apacite}
\bibliography{chap2}

\end{document}

I have tried many times using the {Latex, Bibtex, Latex, Latex} formula. It makes no difference.

There's a similar question answered on 22 Nov 2017 by Danilo Gregorin to a post entitled 'TeXMaker doesn't recognize updates in the .bib file', but I don't know how to set the path he suggests in MikTex.

Does this work if you set the path as suggested or are there any other suggestions?

  • 1
    Welcome to TeX.SX! What does "Quick Build" means (only pdflatex?)? Why does Latex/Bibtex need three passes to clear up all warnings?. – Bobyandbob May 30 '18 at 6:31
  • 1
    In order to update your bibliography you will need to run pdfLaTeX+BibTeX+pdfLaTeX+pdfLaTeX, it might be your issue here. You can set your quickbuild to do that in TexMaker – RockyRock May 30 '18 at 6:35
  • Press F11, press quick build again. – Johannes_B May 31 '18 at 8:52
  • F11 seems to work (amazing solution! who would have known?) only I have to keep repeating it.. Many thanks for 'getting me off the rocks'. – Frances Grundy Jun 1 '18 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.