2

My publisher wants me to have all the editor and author fields in plain text, but actually I got them in smallcaps for the Incollections. How could I fix the issue?

MWE:

% !BIB TS-program = biber
% !BIB program = biber
% !TEX encoding = UTF-8 Unicode
% !TeX TS-program = xelatexmk

\begin{filecontents}{archivio.bib}


@incollection{Sch:Pho,
    Address = {Paris},
    Author = {Jacques Schamp},
    Booktitle = {Dictionnaire des Philosophes Antiques},
    Editor = {Richard Goulet},
    Langid = {french},
    Publisher = {\textsc{cnrs}},
    Title = {Photios},
    Year = {2012}}

\end{filecontents}

\documentclass[11pt, openany]{book}
\usepackage{polyglossia}
\setmainlanguage[babelshorthands=true]{italian}
\setotherlanguages{latin, english, french}

\usepackage[]{csquotes}
\usepackage{xpatch}
\usepackage[style=verbose-trad2,
            language=auto,
            ibidpage=true,
            autolang=other,% use new option name
            useprefix=true,
            giveninits=true,
            indexing=true,% or cite?
            citepages=separate,%
            dateabbrev=false,
            backend=biber,
        ]{biblatex}
\addbibresource{Archivio.bib}   

\DeclareFieldFormat[article, inbook, incollection, inproceedings]{title}{\mkbibemph{#1}}
\DeclareFieldFormat[book, inbook, incollection, inproceedings]{volume}{#1}
\DeclareFieldFormat[article, inbook, incollection, inproceedings]{citetitle}{\mkbibemph{#1}}

\begin{document}

\textit{Incollection:}\\
\cite[]{Sch:Pho}\\

\printbibliography
\end{document}
2
  • 2
    This results from your use of langid={french} for your bibentry and autolang=other. Small caps is a setting for the french language in biblatex, not for incollection. Would you like this changed for this particular entry, for french overall, or to not use autolang=other?
    – gusbrs
    Commented May 30, 2018 at 16:06
  • I need the language specification for other custom settings, but I want all author and editor names to be printed in normal plain text
    – Teodoro
    Commented May 30, 2018 at 16:13

1 Answer 1

3

The small caps in your example does not emerge because this is an incollection entry, but rather because that particular entry has langid={french} and you use autolang=other as a biblatex setting. And french.lbx is set to typeset family names in small caps. As you want to keep the language specification, you should redefine this for french with:

\DefineBibliographyExtras{french}{%
  \renewcommand*{\mkbibnamefamily}[1]{\textnohyphenation{#1}}%
}

In full:

% !BIB TS-program = biber
% !BIB program = biber
% !TEX encoding = UTF-8 Unicode
% !TeX TS-program = xelatexmk

\begin{filecontents}{archivio.bib}


@incollection{Sch:Pho,
    Address = {Paris},
    Author = {Jacques Schamp},
    Booktitle = {Dictionnaire des Philosophes Antiques},
    Editor = {Richard Goulet},
    Langid = {french},
    Publisher = {\textsc{cnrs}},
    Title = {Photios},
    Year = {2012}}

\end{filecontents}

\documentclass[11pt, openany]{book}
\usepackage{polyglossia}
\setmainlanguage[babelshorthands=true]{italian}
\setotherlanguages{latin, english, french}


\usepackage[]{csquotes}
\usepackage{xpatch}
\usepackage[style=verbose-trad2,
            language=auto,
            ibidpage=true,
            autolang=other,% use new option name
            useprefix=true,
            giveninits=true,
            indexing=true,% or cite?
            citepages=separate,%
            dateabbrev=false,
            backend=biber,
            ]{biblatex}

\DefineBibliographyExtras{french}{%
  \renewcommand*{\mkbibnamefamily}[1]{\textnohyphenation{#1}}%
}

\addbibresource{Archivio.bib}   

\DeclareFieldFormat[article, inbook, incollection, inproceedings]{title}{\mkbibemph{#1}}
\DeclareFieldFormat[book, inbook, incollection, inproceedings]{volume}{#1}
\DeclareFieldFormat[article, inbook, incollection, inproceedings]{citetitle}{\mkbibemph{#1}}

\begin{document}

\textit{langid={french}:}\\
\cite[]{Sch:Pho}\\

\printbibliography
\end{document}

enter image description here

2
  • 1
    Slightly shorter, but without the \textnohyphenation would be \DefineBibliographyExtras{french}{\restorecommand\mkbibnamefamily}.
    – moewe
    Commented May 30, 2018 at 16:50
  • @moewe, that's for the insiders who noticed the command was even saved in the first place.
    – gusbrs
    Commented May 30, 2018 at 16:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .