0

I would like to Change behavior of tab erasing in the WinEdt editor. When I insert a tab (pressing the tab key), it does insert a tab, but if right after that I press backspace to erase it, it erases single space characters, one at a time. Thus, in order to erase a full tab I need to press backspace e.g. 4 times. Is it possible to change the program behavior so that backspace deletes the full tab inserted (just as, e.g., Notepad++ does)? Thanks and regards, Jorge.

  • 1
    Are you really sure that you insert a TAB after pressing the <kbd>Tab</kbd> key and not 4 spaces? Nonetheless to "delete" the TAB/4 spaces you can press <kbd>Shift</kbd>+<kbd>Tab</kbd> to delete them. – Stefan Pinnow May 30 '18 at 21:21
  • Thanks for the tip, Stefan! Shift+Tab does seem to erase the tab. As to what am I actually inserting, I don't really know: is there a way to make Winedt display the whitespace characters like space, tab, line return, etc? – dontpanic May 30 '18 at 22:01
  • @StefanPinnow Would you write an answer? – Arzigoglu May 31 '18 at 4:32
  • @Arzigoglu, sure. Done. – Stefan Pinnow May 31 '18 at 4:59
3

If you have written your document in WinEdt it is very likely that there are no (real) TABs in it. By default pressing ↹ TAB 4 spaces are inserted.

Nonetheless instead of using ⇦ Backspace you could press ⇧ Shift+↹ TAB to delete either a TAB or (up to) 4 spaces.


To set options regarding the TAB in WinEdt goto
        Options > Options Interface > Font Schemes: ... > Tabs
where you can e.g. set

  • the TAB length
  • how TABs "behave"
  • if TABs should be drawn
  • if TABs are allowed as input chars
  • if a TAB should be inserted when ↹ TAB is pressed

After applying your settings don't forget to press the
        Load Current Script
button!


(To test, if you have TABs inside your document you could also do a simple search in the file(s), but therefore you have to ensure that you really have a TAB in the search bar. I ensure this by copying it from another application.)

  • Thank you guys for your help. Using the aforementioned procedure, I set TAB_ALLOW_KEYBOARD=1 and now the editor is actually inserting tabs instead of spaces. – dontpanic May 31 '18 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.