0

I wish the A, B and C of the matrices defined as follow were written using the default computer modern font. I'm using the fontspec package with LuaLaTeX, but when I set the main font it also changes the math bold font. Here's an excerpt of my document:

\documentclass[12pt,a4paper]{report}

\usepackage{polyglossia}
    \setdefaultlanguage{english}
    \disablehyphenation

\usepackage[
    hmarginratio = 1:1,
    left = 3cm,
    right = 2cm,
    top = 3cm,
    bottom = 2cm
    ]{geometry}

\usepackage{fontspec}
    \setmainfont{Arno Pro}

\usepackage{amsmath}
\usepackage{lipsum}

\begin{document}

\lipsum[1]

\begin{center}
    $ {\bf A}_{2\times 3}=\begin{pmatrix}
    1 & 2 & 3 \\
    4 & 5 & 6
    \end{pmatrix}
    %
    \hspace{.5cm}
    %
    {\bf B}_{4\times 3}=\begin{bmatrix}
    1 & 2 & 3 \\
    4 & 5 & 6 \\
    7 & 8 & 9 \\
    1 & 2 & 3
    \end{bmatrix}
    %
    \hspace{.5cm}
    %
    {\bf C}_{2\times 2}=\begin{Vmatrix}
    1 & 2 \\
    3 & 4
    \end{Vmatrix} $
\end{center}

\lipsum[2]

\end{document}

Bold Math font changes as well

As you can see the bold math font is not the computer modern but the numbers are. Although both of them are inside the math environment.

  • 4
    Don't use \bf. See tex.stackexchange.com/q/516/35864 and tex.stackexchange.com/q/15361/35864. \mathbf seems more appropriate here. But I'm not sure if this solves your problem. But even if not, you should definitely not be using \bf any more anywhere. – moewe May 31 '18 at 13:53
  • 3
    Use \usepackage[no-math]{fontspec} if you don't want fontspec to interfere. – Ulrike Fischer May 31 '18 at 13:54
  • I tried it, but i get the following error: ! LaTeX Error: Option clash for package fontspec. See the LaTeX manual or LaTeX Companion for explanation. Type H <return> for immediate help. ... l.16 \setmainfont {Arno Pro} The package fontspec has already been loaded with options: [] There has now been an attempt to load it with options [no-math] Adding the global options: ,no-math to your \documentclass declaration may fix this. Try typing <return> to proceed. – Levy May 31 '18 at 13:58
  • 1
    Re the option clash: Load fontspec before polyglossia. – moewe May 31 '18 at 14:02
  • 1
    In the MWE things work for me (with Linux Libertine instead of Arno Pro, but that should be irrelevant) if I load \usepackage[no-math]{fontspec} before polyglossia and use \mathbf. – moewe May 31 '18 at 14:06
1

Answer:

With the help of the members @moewe and @Ulrike Fischer in the comments I loaded the fontspec package before the polyglossia with the option [no-math]and also changed the {\bf } to \mathbf{}.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.