1

I am writing a journal article for Elsevier. I am finishing it, but I have noted that the references appear not compressed.

For example, in my article the references appear as the following

...[1], [2], [3]

Instead of

...[1–3]

Could anyone help me to fix it?

I am working with the following preamble

\documentclass[preprint,12pt]{elsarticle}
% !TeX spellcheck = en_US 
\usepackage{siunitx}
\sisetup{detect-weight, detect-display-math}
\sisetup{detect-inline-weight=math}
\sisetup{mode=text,per-mode=symbol}
\usepackage{booktabs}
\usepackage{graphicx}
\usepackage{pgfplots}
\usepackage{pdflscape}
\pgfplotsset{compat=newest}
\usetikzlibrary{plotmarks}
\usetikzlibrary{arrows.meta}
\usepgfplotslibrary{patchplots}
\newlength\fwidth
\setlength{\fwidth}{0.8\textwidth}
\pgfplotsset{plot coordinates/math parser=false}
\usepackage{overpic}
\pgfplotsset{compat=1.15}
\usepackage{float}
\usepackage{etoolbox}
\usepackage{bicaption}
\usepackage{makecell}
\renewcommand\theadfont{\bfseries}
\renewcommand\theadgape{}
\usepackage[skip=1ex, labelfont=bf]{caption}
\usepackage[skip=0.333\baselineskip]{caption}
\usepackage{tabularx}
\newcolumntype{C}{>{\centering\arraybackslash}X}
\def\UrlFont{\normalfont}
\sisetup{per-mode=symbol}
\usepackage[margin=2.5cm]{geometry} 
\usepackage[skip=0.333\baselineskip]{caption}
\usepackage{amssymb,amsmath}
\usepackage{url}
\usepackage{hyperref}
\bibliographystyle{unsrt}
\journal{Fuel}

\begin{document}

\begin{frontmatter}


\end{frontmatter}


\cite{jiang2007new,jiang2007progress,hotta2005experience}    

\section*{References}

\bibliography{bilbiography}

\end{document}

\endinput

Please use the following citations as bibliography.bib:

@article{hotta2005experience,
    title={EXPERIENCE OF ESTONIAN OIL SHALE COMBUSTION BASED ON CFB TECHNOLOGY AT NARVA POWER PLANTS.},
    author={Hotta, A and Parkkonen, R and Hiltunen, M and Arro, H and Loosaar, J and Parve, T and Pihu, T and Prikk, A and Tiikma, T},
    journal={Oil shale},
    volume={22},
    number={4},
    year={2005}
}

@article{uibu2009co2,
    title={CO2 mineral sequestration in oil-shale wastes from Estonian power production},
    author={Uibu, Mai and Uus, Mati and Kuusik, Rein},
    journal={Journal of environmental management},
    volume={90},
    number={2},
    pages={1253--1260},
    year={2009},
    publisher={Elsevier}
}
@article{jiang2007new,
    title={New technology for the comprehensive utilization of Chinese oil shale resources},
    author={Jiang, XM and Han, XX and Cui, ZG},
    journal={Energy},
    volume={32},
    number={5},
    pages={772--777},
    year={2007},
    publisher={Elsevier}
}

@article{jiang2007progress,
    title={Progress and recent utilization trends in combustion of Chinese oil shale},
    author={Jiang, XM and Han, XX and Cui, ZG},
    journal={Progress in Energy and Combustion Science},
    volume={33},
    number={6},
    pages={552--579},
    year={2007},
    publisher={Elsevier}
}
2

Assuming that you are already using \cite{a,b,c}, you can accomplish this by adding the following to your preamble:

\biboptions{sort&compress}

You can see this in an example I have created on Overleaf.

1

To quote from the elsarticle manual:

If you want to add extra options of natbib.sty, you may use the options as comma delimited strings as arguments to \biboptionscommand.

[...]

sort&compress sorts and compresses the numbered citations. For example, citation [1,2,3] will become [1–3]

You might therefor achieve the desied result, by including the following line in your preamble:

\biboptions{sort&compress}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.