When combining biblatex with beamerposter, I get a weird symbol in place of the bibliography reference counter. Here's the minimum code I used to reproduce my issue.

MWE:

\documentclass[t]{beamer}
\usepackage[orientation=landscape,size=a1,scale=1.4]{beamerposter}
\usepackage[absolute,overlay]{textpos}
\usepackage[backend=biber, maxbibnames=2, maxcitenames=2, sortcites=true, style=authoryear]{biblatex}
\renewcommand*{\bibfont}{\small}

\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{dr1957cat,
title={The Cat in the Hat},
author={Seuss, Dr. and Ginsburg, Avi},
series={Beginner books},
year={1957},
publisher={Random House}
}
\end{filecontents*}

\addbibresource{\jobname.bib}

\usetheme{default}
\useinnertheme{rectangles}

\begin{document}

\begin{frame}[label={sec:org1b2094c}]{}
\begin{columns}
\begin{column}{0.9\columnwidth}
\begin{block}{Introduction}
Fusce sagittis, libero non molestie mollis, magna orci ultrices dolor, at vulputate neque nulla lacinia eros. Aliquam erat volutpat.  Nunc eleifend leo vitae magna. \cite{dr1957cat}  In id erat non orci commodo lobortis.  Proin neque massa, cursus ut, gravida ut, lobortis eget, lacus.
\end{block}

\begin{block}{References}
\printbibliography
\end{block}
\end{column}
\end{columns}
\end{frame}
\end{document}

Here's a picture of the problem, note the small "paper" symbol instead of the reference counter:

enter image description here

For completeness, I tried compiling the document with both pdflatex and xelatex using the following commands:

latexmk -pdflatex='pdflatex -shell-escape -interaction nonstopmode' -pdf -bibtex -f %f"

and

latexmk -pdflatex='xelatex -interaction nonstopmode' -pdf -bibtex -f %f"

Texlive 2016 on a CentOS machine.

Has anyone seen this before? What can I do to fix this? Thank you.

up vote 2 down vote accepted

If you don't like this cute little symbol, you can disable it with \setbeamertemplate{bibliography item}{}

\documentclass[t]{beamer}
\usepackage[orientation=landscape,size=a1,scale=1.4]{beamerposter}
\usepackage[absolute,overlay]{textpos}
\usepackage[backend=biber, maxbibnames=2, maxcitenames=2, sortcites=true, style=authoryear]{biblatex}
\renewcommand*{\bibfont}{\small}

\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{dr1957cat,
title={The Cat in the Hat},
author={Seuss, Dr. and Ginsburg, Avi},
series={Beginner books},
year={1957},
publisher={Random House}
}
\end{filecontents*}

\addbibresource{\jobname.bib}

\usetheme{default}
\useinnertheme{rectangles}


\setbeamertemplate{bibliography item}{}
%\setbeamertemplate{bibliography item}{\insertbiblabel}% for numeric bib styles

\begin{document}

\begin{frame}[label={sec:org1b2094c}]{}
\begin{columns}
\begin{column}{0.9\columnwidth}
\begin{block}{Introduction}
Fusce sagittis, libero non molestie mollis, magna orci ultrices dolor, at vulputate neque nulla lacinia eros. Aliquam erat volutpat.  Nunc eleifend leo vitae magna. \cite{dr1957cat}  In id erat non orci commodo lobortis.  Proin neque massa, cursus ut, gravida ut, lobortis eget, lacus.
\end{block}

\begin{block}{References}
\printbibliography
\end{block}
\end{column}
\end{columns}
\end{frame}
\end{document}
  • It's cute, but unexpected. I thought I had problems with my fonts. In any case, thank you for your answer. – dangom May 31 at 15:58
  • @dangom You don't use beamer often enough if it is enexpected :) – samcarter May 31 at 15:59
  • No, it's indeed the first time. – dangom May 31 at 16:00
  • Would \setbeamertemplate{bibliography item}{\insertbiblabel} not be safer in case one decides to use a numeric style? Or is there something more to it? – moewe May 31 at 16:11
  • @moewe On the other hand it might be confusing to see \setbeamertemplate{bibliography item}{\insertbiblabel} in the code and nothing is displayed for authoryear style. – samcarter May 31 at 16:17

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.