1

I am using the following font in a XeLaTeX compiled document https://www.whatfontis.com/FF_Pali.font

All seemed to be well, until I noticed that when there are two of a certain characters next to each other (i.e., AA, II), just a single letter with a line over it is produced. This does not happen with different fonts, which points to an issue with the font. Has anyone else ever had this happened and did you figure out how to fix it? Also happens in report and article classes.

Example:

\documentclass[12pt]{book}
\usepackage{fontspec}
\setmainfont{Pali}

\begin{document}
\Huge AA II
\end{document}

Log file:

This is XeTeX, Version 3.14159265-2.6-0.99998 (TeX Live 2017) (preloaded format=xelatex)
 restricted \write18 enabled.
entering extended mode
(./margin_test.tex
LaTeX2e <2017-04-15>
Babel <3.10> and hyphenation patterns for 22 language(s) loaded.
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/base/book.cls
Document Class: book 2014/09/29 v1.4h Standard LaTeX document class
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/base/bk12.clo))
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/fontspec/fontspec.sty
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/l3kernel/expl3.sty
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/l3kernel/expl3-code.tex)
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/l3kernel/l3xdvipdfmx.def))
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/l3packages/xparse/xparse.sty
)
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/fontspec/fontspec-xetex.sty
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/base/tuenc.def))
(/usr/local/texlive/2017basic/texmf-dist/tex/latex/fontspec/fontspec.cfg)))
(./margin_test.aux) [1] (./margin_test.aux) )
Output written on margin_test.pdf (1 page).
SyncTeX written on margin_test.synctex.gz.
Transcript written on margin_test.log.
4

This font, of dubious legality, defines contextual ligatures for the convenience of the Association for Insight Meditation, which claims to hold the copyright. See the Pali.ot file included in the archive:

lookup ContextualLigatures {
sub A A -> Amacron; 
sub a a -> amacron; 
sub I I -> Imacron; 
sub i i -> imacron; 
sub U U -> Umacron; 
sub u u -> umacron; 
sub quotedbl S -> Sacute; 
sub quotedbl s -> sacute; 
sub period D -> Ddotbelow; 
sub period d -> ddotbelow; 
sub period H -> Hdotbelow; 
sub period h -> hdotbelow; 
sub period L L -> Ldotbelowmacron; 
sub period l l -> ldotbelowmacron; 
sub period L -> Ldotbelow; 
sub period l -> ldotbelow; 
sub quotedbl M -> Mdotaccent; 
sub quotedbl m -> mdotaccent; 
sub period M -> Mdotbelow; 
sub period m -> mdotbelow; 
sub asciitilde N -> Ntilde; 
sub asciitilde n -> ntilde; 
sub quotedbl N -> Ndotaccent; 
sub quotedbl n -> ndotaccent; 
sub period N -> Ndotbelow; 
sub period n -> ndotbelow; 
sub period R R -> Rdotbelowmacron; 
sub period r r -> rdotbelowmacron; 
sub period R -> Rdotbelow; 
sub period r -> rdotbelow; 
sub period S -> Sdotbelow; 
sub period s -> sdotbelow; 
sub period T -> Tdotbelow; 
sub period t -> tdotbelow; 
}

You can either turn off contextual ligatures (they’re on by default) or use TeX Gyre Pagella if it suits your needs.

  • Thank you Thérèse, I disabled contextual ligatures when setting the font and that fixed it. \setmainfont[Ligatures=NoContextual]{Pali} – kwodzicki Jun 4 '18 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.