2

I am using CambridgeUS theme and I would like to remove frame numbers in the bottom right portion of the screen without actually destroying the theme.

Is that possible?

See in the below picture, the placeholder image will be my company logo and I want 1/1 next to it to disappear.

This is because there will be around 20 slides and as the numbers go from 1/20 through 10/20 that extra digit there causes my company logo to go a bit left, looks ugly in transition. I dont think I will be needing the frame numbers as this is only a 20 minute presentation.

Here is the code for below output:

\documentclass[12pt, xcolor=dvipsnames]{beamer}
\beamertemplatenavigationsymbolsempty  %no navigation pane
\usetheme{CambridgeUS}
\usecolortheme{seahorse}


\title[Topic of the Presentation]{Topic of the Presentation}
\author[Person]{Person}
%\subtitle{}
%\setbeamercovered{transparent} 
%\setbeamertemplate{navigation symbols}{} 
%\log_2o
\institute[]{\includegraphics[height=1.5cm]{placeholder.jpg}}
\date[{\includegraphics[height=2mm]{placeholder.jpg}}]{June 21st, 2018} 
%\subject{} 

\begin{document}

\begin{frame}[noframenumbering, plain]
\titlepage
\end{frame}



\section{some section}
\subsection{some subsection}
\begin{frame}{\centerline{A Slide}}

Some Stuff

\end{frame}

\end{document}

Thank you so much!

enter image description here

  • Welcome to TeX.SX! – Bobyandbob Jun 3 '18 at 15:33
  • Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – dexteritas Jun 3 '18 at 15:38
  • From the little logo in your footline I guess your using some custom footline definition. Please make a minimal working example (MWE) that shows how you set up your footline. – user36296 Jun 3 '18 at 17:06
  • The too high placement of the text in your headline and name/title makes me think that you probably have an outdated beamer version. – user36296 Jun 3 '18 at 17:07
  • My TexLiveUtility stopped working which is what I used for updating, but I guess you are right. There is 2018 Tex distribution available now, which I never installed. High placement of the text in headline and footline was annoying me, I hope that updating will be fixing it. Thanks! – Semzem Jun 4 '18 at 15:20
4

Using \setbeamertemplate{page number in head/foot}{} should do the trick.

\documentclass{beamer}
\usetheme{CambridgeUS}
\setbeamertemplate{page number in head/foot}{}
\begin{document}
\begin{frame}
\frametitle{A frame}
This is a frame
\end{frame}
\end{frame}
\end{document}

output of code

  • 1
    Another option is to set the frame numbering inside a fixed-width box that is right-aligned. For example, \setbeamertemplate{page number in head/foot}{\makebox[5em][r]{\insertframenumber/\inserttotalframenumber}}... Adjust 5em accordingly. – Werner Jun 3 '18 at 16:47
  • This did not resolve my issue. But my Tex distribution is old, it could be that. I will try once it finishes updating. – Semzem Jun 4 '18 at 15:21
  • Ok, thanks! This solves it but I need the 2018 distribution! – Semzem Jun 4 '18 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.