I would like to sort my bibliography by title in the case there is no author but just the editor. Now it is sorting by editor.

So in my example I would like to have first "Concilium Foroiuliense" and then Hergenröther.

There are lots of threads about sorting but I couldn't find one with this (or a close related) issue. Should I redefine the alphabetic template (biblatex manual p.257), use a sortkey or... what?


% !BIB TS-program = biber
% !BIB program = biber
% !TEX encoding = UTF-8 Unicode
% !TeX TS-program = xelatexmk


    Address = {Ratisbonae},
    Editor = {Joseph Hergenröther},
    Langid = {german},
    Publisher = {Manz},
    Title = {Monumenta graeca ad Photium},
    Year = {1869}}

    Address = {Hannoverae-Lipsiae},
    Booktitle = {Monumenta Germaniae Historiae. Legum \textsc{iii}. Concilia aevi Karolini \textsc{ii}/1},
    Editor = {Albertus Werminghoff},
    Langid = {german},
    Pages = {177-95},
    Publisher = {Impensis Bibliopolii Hahniani},
    Title = {Concilium Foroiuliense},
    Year = {1906}}


\documentclass[11pt, openany]{book}
\setotherlanguages{latin, english, french, german}

            autolang=other,% use new option name
            indexing=true,% or cite?


First, I'm citing this\footcite{Mgh:Aqu}\\
Then this\footcite{Her:Mon}

1 Answer 1


useeditor is the option you are looking for. If useeditor is set to false the editor will appear after the title and the work will be sorted by title.

You can add the option globally for all @incollection entries with


or locally for only specific books by using the options field in the .bib file

  address   = {Hannoverae-Lipsiae},
  booktitle = {Monumenta Germaniae Historiae. Legum \textsc{iii}. Concilia aevi Karolini \textsc{ii}/1},
  editor    = {Albertus Werminghoff},
  langid    = {german},
  pages     = {177-95},
  publisher = {Impensis Bibliopolii Hahniani},
  title     = {Concilium Foroiuliense},
  year      = {1906},
  options   = {useeditor=false},

I would not set \ExecuteBibliographyOptions{useeditor=false} for all entries since @collections and Her:Mon in your example should probably still be associated with their editors.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .