2

I have a problem with my bibliography: with my settings, by default the bibliography does not appear in the table of contents (toc). So I included \usepackage{tocbibind} into my preamble which solved this problem, but caused another problem: with the \documentclass{scrbook}, on top of each page it is written, to which chapter or section the current page belongs to. After using tocbibind, this heading (?) (I don't know the technical term for this) is always capitalized ("BIBLIOGRAPHY"), but I want it to be "Bibliography" (which was given before tocbibind was included). The title of the bibliography at page 7 in the MWE below is "Bibliography", but at page 8 it is "BIBLIOGRAPHY" (see picture below).

page 8

Somehow it is the opposite of this question, I want it to be sentence case everywhere: in the toc, at the start of the bibliography, at the headings of each page.

Using the code from this answer, my MWE is:

\documentclass{scrbook} 
\usepackage{blindtext}
\usepackage{tocbibind}
\usepackage{filecontents}

\begin{filecontents}{jobname.bib}
@book{author_book,
title = {\blindtext[5]},
author = {Author, Some},
location = {The City},
publisher = {Publisher},
year = {2005},
}

\end{filecontents}

\begin{document}
\tableofcontents
\chapter{The first chapter}
\section{First Section}

\blindtext[10]
\section{Second Section}
\blindtext[5]
\nocite{*}

\bibliographystyle{abbrv}
\bibliography{jobname}

\end{document}
  • I tried your MWE and the use, or not, of tocbibind had no effect on the appearance of the Bibliography page. It did effect whether or not the Bibliography was listed in the ToC. – Peter Wilson Jun 4 '18 at 18:26
  • @PeterWilson The heading on page 8 should change. The "Bibliography" title on page 7 remains unchanged. – Qaswed Jun 4 '18 at 18:42
2

Remove package tocbibind and use KOMA-Script option bibliography=totoc:

\documentclass[bibliography=totoc]{scrbook} 
\usepackage{blindtext}
\usepackage{filecontents}

\begin{filecontents}{jobname.bib}
@book{author_book,
title = {\blindtext[5]},
author = {Author, Some},
location = {The City},
publisher = {Publisher},
year = {2005},
}

\end{filecontents}

\begin{document}
\tableofcontents
\chapter{The first chapter}
\section{First Section}

\blindtext[10]
\section{Second Section}
\blindtext[5]
\nocite{*}

\bibliographystyle{abbrv}
\bibliography{jobname}

\end{document}

enter image description here

enter image description here

If the ToC should also get a ToC entry, then add

\setup{toc}{totoc}

to the preamble.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.