1

IOP Publishing journals require that, if there are more than two authors, only the first name should appear, followed by "et al." (using \etal in iopart.cls). However, the dcu bibliography style (recommended by iopart) includes all authors in the text in the first citation if the harvard citation management package is loaded. Is there any way to solve this conflict? I would like to use Harvard style with no more than two authors in the text.

To be more specific, I am creating an iopart document and using the Harvard alphabetical style for references. I am reading from a bib file, and use \citeasnoun{ref} in the text. I also use dcu.bst to include article titles in the references.

  • 1
    Do you want to change the dcu.bst style to get this abbreviation? (Adding a MWE to your question will be a good idea to help the other readers to understand what you want). – Mohamed Vall Jun 6 '18 at 22:51
1

For publications with 3 or more authors and if the harvard citation management package is loaded, the dcu bibliography style is designed to include the names of all authors of a given publication the first time the publication is cited; from the second citation onward, the abbreviated form firstauthor et al is used for citation call-outs.

The user guide of the harvard package mentions that the default setting can be overridden, i.e., that one can generate abbreviated citation call-outs beginning with the very first time a piece is cited, by issuing the instruction

\citationmode{abbr}

after loading the harvard package in the preamble.


A full MWE (minimum working example):

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@misc{abc, author="Author and Buthor and Cuthor", title="Title", year=3001}
\end{filecontents}

\documentclass{iopart}
\usepackage{harvard}
\bibliographystyle{dcu}
\citationmode{abbr}  % <-- new

\begin{document}
\noindent
\citeasnoun{abc} argue that \dots
\section*{References}
\bibliography{mybib}
\end{document}

A different solution may be achieved by not loading the harvard package at all and, instead, by loading the natbib package, all while still using the dcu bibliography style. With this solution, it's actually best to load the har2nat package, which loads the natbib package automatically while preserving some of the special capabilities of the harvard package.

A full MWE (no screenshot provided, as it would be essentially the same as the one shown above):

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@misc{abc, author="Author and Buthor and Cuthor", title="Title", year=3001}
\end{filecontents}

\documentclass{iopart}
\usepackage{har2nat}  % loads 'natbib' automatically
\bibliographystyle{dcu}
\providecommand\newblock{} % suppress some meaningless warnings

\begin{document}
\noindent
\citet{abc} argue that \dots
\bibliography{mybib}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.