2

I need to use Chicago 17th ed. style for my references. The code below does the job but the \cite command for in-text citations prints the full reference (as \fullcite is actually supposed to do).

What's wrong?

Here a minimal example:

\documentclass{article}
\usepackage[utf8]{inputenc}

\usepackage[backend=bibtex]{biblatex-chicago}

\begin{filecontents}{bibfile.bib}

@article{gamow1946expanding,
    title={Expanding universe and the origin of elements},
    author={Gamow, George},
    journal={Physical Review},
    volume={70},
    number={7-8},
    pages={572},
    year={1946},
    publisher={APS}
}


\end{filecontents}

\addbibresource{bibfile.bib}
\begin{document}

    \cite{gamow1946expanding}
    \printbibliography
\end{document}

This is the output: enter image description here

6
  • 2
    You did not tell biblatex-chicago which style to use. Did you try something like \usepackage[authordate]{biblatex-chicago} or \usepackage[notes]{biblatex-chicago}?
    – gusbrs
    Commented Jun 5, 2018 at 17:09
  • 2
    Off topic: Both biblatex and biblatex-chicago recommend biber as the backend, do you have a strong reason to use backend=bibtex?
    – gusbrs
    Commented Jun 5, 2018 at 17:10
  • @gusbrs using the notes option does not solve the problem. Regarding backend, actually I do not have any reason to opt for that and I can change it to biber. Did you run the code above and got the same output as mine?
    – Caserio
    Commented Jun 5, 2018 at 17:23
  • 1
    Ah! I see what is likely going on! notes must be the default of biblatex-chicago. And, the first occurrence of a citation in that style is indeed similar to a bibliography entry and is expected to be given in footnote (with \footcite). To check if this is the case, test two things: 1) the authordate option (and you will see the citation format change); 2) with the notes option, change cite to footcite and add a second citation of the same bibentry (you will see the second instance as "ibid." or, if there's another between them, a short form).
    – gusbrs
    Commented Jun 5, 2018 at 17:48
  • What you suggest partially works. In fact, by using the authordate option I get Surname Year. However, there is not comma between the two and no parenthesis for the year. Could you suggest how to costumize the style?
    – Caserio
    Commented Jun 5, 2018 at 18:55

1 Answer 1

2

biblatex-chicago's default is the notes style, which will render a full citation (bibliography like) on its first appearance and then a short version of it in subsequent citations (if not ibid.). This style is supposed to work with citations given in footnotes. So what you get is the expected result. If you'd like label-like citations to be given inline, you can use the authordate style of biblatex-chicago and then use \textcite or \parencite as needed.

\documentclass{article}
\usepackage[utf8]{inputenc}

\usepackage[authordate]{biblatex-chicago}

\begin{filecontents}{bibfile.bib}
@article{gamow1946expanding,
    title={Expanding universe and the origin of elements},
    author={Gamow, George},
    journal={Physical Review},
    volume={70},
    number={7-8},
    pages={572},
    year={1946},
    publisher={APS}
}
\end{filecontents}

\addbibresource{bibfile.bib}

\begin{document}

\textcite{gamow1946expanding}

\parencite{gamow1946expanding}

\printbibliography

\end{document}

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .