0

I'm using Winedt 10 to write my thesis and I have somehow managed to press some button or quick command that has stopped the text from wrapping inside the editor. This means that when writing, the line will just continue, seemingly for ever, until I hit the return key. The consequence is that I can't read the entire previous line without scrolling to the right in the editor. Needless to say, I don't want to compile the document into a pdf to be able to read what I have written. Secondly, hitting the return key ever 15 seconds is irritating. Based on answers provided in this post: line breaks in editors window

, which basically has the same problem, I have tried to go to "Options/Preferences/Wrapping and select the "Use fixed right margin", and then set this at various lower values. However, this changes the margin in the pdf, but does not have any effect on the wrapping of the text in the editor. As you can see from the image, the line just continues, whereas I would like it broken approximately at the right edge of this image.

Any ideas?

enter image description here

  • Under the "Wrapping" tab, are there checkmarks in the boxes labeled "Enable Wrapping for Modes:" and "Use Soft Wrapping for Modes:"? And, what's the number at which wrapping is supposed to occur? – Mico Jun 7 '18 at 10:35
  • 2
    Check in the status line on the bottom if you have disabled "Wrap". – Ulrike Fischer Jun 7 '18 at 10:42
  • @UlrikeFischer, indeed I had disabled the wrap function at the bottom. When I clicked it, everything came back to normal. Furthermore, it seems that Ctrl + W does the same trick. So the solution was very simple. Thanks! – EspenJK Jun 7 '18 at 11:39
4

Check the status of the Wrap field in the status bar at the bottom:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.