Recently, MikTeX came through a large update that introduces MikTeX console. Since then I have troubles figuring out what to do in particular situations.

Recently I wanted to install MinionPro package, a task I successfully finished several times to date. However, when trying to use it, I get error

! LaTeX Error: File `minionpro.sty' not found.

Funny thing is that the file is on the disk, in C:\Program Files\MiKTeX 2.9\tex\latex\MinionPro folder.

I first thought that some (FNDB) refreshing is needed, but I can't find that in the MikTeX console. Next I tried to do that from the command console writing

texhash
initexmf -u
updmap

in both administrator and normal mode. To no avail.

How to solve that problem?

  • You can refresh the file name database in the Console via "Tasks > Refresh file name database" in the menu – moewe Jun 8 at 11:18
  • Thanks for the hint - I really did not see that. Now it works, finally. But why is command line update not working? – Pygmalion Jun 8 at 11:23
  • Not sure. Some command line tools need to be passed the --admin flags when run in Admin mode. But I expected the commands to complain if it is missing, not to fail silently... – moewe Jun 8 at 11:25
  • I already tried that. Without --admin I get no error; with --admin flag I get error, can't recall which one now. – Pygmalion Jun 8 at 11:30
  • initexmf --admin -u should imho work. If not you should make a bug report (and first get the exact error message). initexmf -u will only update the fndb of the user trees. – Ulrike Fischer Jun 8 at 11:42
up vote 0 down vote accepted

Anyway, the file should be in a Local-TeXMF root, not in the distribution root. If you do not have one, create it, and install in it all your local additions, respecting the TeX Directory Structure.

This being said, you can refresh the FNDB from MiKTeX console wopening the Tasks menu, which has sub menu for this job, to refresh font map files (after you've installed support for a type 1 font) and to update the package database:

enter image description here

  • I didn't put it in distribution root, MikTeX did it itself. – Pygmalion Jun 9 at 6:18
  • @Pygmalion: But, as far as I know, it's not in the distribution (nor in TeX Live)! It has to be installed by hand. How comes you have it in MiKTeX TeXMF root? – Bernard Jun 9 at 8:14
  • No idea! I did not install it manually. – Pygmalion Jun 9 at 14:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.