0

I would like to add a vertical dashed line between the third and fourth column. The following is my code. This code is working well with my thesis template, but a vertical dashed line is not appearing in my manuscript template. No error, but just no vertical line. Document class is 'article'.

\begin{align*}
\left[ 
\begin{array}{ccc:ccc}
a_{11} b_{11} & a_{11} b_{12} & a_{11} b_{13} & a_{12} b_{11} & a_{12} b_{12} & a_{12} b_{13} \\
a_{11} b_{21} & a_{11} b_{22} & a_{11} b_{23} & a_{12} b_{21} & a_{12} b_{22} & a_{12} b_{23} \\
a_{11} b_{31} & a_{11} b_{32} & a_{11} b_{33} & a_{12} b_{31} & a_{12} b_{32} & a_{12} b_{33} \\
\hdashline [2pt/2pt]
a_{21} b_{11} & a_{21} b_{12} & a_{21} b_{13} & a_{22} b_{11} & a_{22} b_{12} & a_{22} b_{13} \\
a_{21} b_{21} & a_{21} b_{22} & a_{21} b_{23} & a_{22} b_{21} & a_{22} b_{22} & a_{22} b_{23} \\
a_{21} b_{31} & a_{21} b_{32} & a_{21} b_{33} & a_{22} b_{31} & a_{22} b_{32} & a_{22} b_{33}
\end{array}
\right] 
\end{align*}

And there are the list of packages that I am currently using now. (Order is preserved.)

\usepackage{amssymb}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{array}
\usepackage{tabularx}
\usepackage{longtable}
\usepackage{multirow}
\usepackage{arydshln} 
\usepackage{mathtools}
\usepackage{changepage}
\usepackage[utf8x]{inputenc}
\usepackage{textcomp,marvosym}
\usepackage{nameref,hyperref}

What I am thinking is:

  1. {ccc:ccc} is not functioning right. But no error.
  2. Considering that this code works fine with my thesis template, one of the packages might be interrupping, while I do not know what that is.

I was suffering from this problem for an entire day! Any advice and suggestions will be greatly appreciated and welcomed!

2
  • Welcome to TeX SX! Your code misses a \right].
    – Bernard
    Commented Jun 8, 2018 at 20:46
  • Hi Bernard. Thank you for noticing this. I have \right] in my code, indeed. I modified this post just in case.
    – KLee
    Commented Jun 8, 2018 at 22:02

1 Answer 1

0

OutputIt seems to work for me — though note Bernard's comment; you have missed a \right] .

Edit:

Using the template linked:

TemplateOutput

Have you tried compiling with a non-dashed line? There's nothing wrong with the code you used, and the packages you're using aren't mucking it up. Maybe try switching compilers?

7
  • Hi Infiaria. I am having the same problem. It perfectly is working in my thesis template. However, not in the different template. Currently I am using a manuscript template obtained from PLOS Computational Biology, but somehow the vertical line is not shown without any error!
    – KLee
    Commented Jun 8, 2018 at 22:04
  • @rudgus51998 I did read your post, yes. But I don't think I can help you here, since I can't seem to reproduce it (using the code you gave). It might help if you link to the template.
    – Infiaria
    Commented Jun 9, 2018 at 3:29
  • Thank you for your help! journals.plos.org/ploscompbiol/s/latex <- From here, you can download the exactly same template that I am using now. You might need to add some packages (listed above in the original post) such as 'arydshln' by yourself though. I sincerely appreciate your help!!
    – KLee
    Commented Jun 9, 2018 at 15:25
  • @rudgus51998 Unfortunately, I still can't seem to reproduce what you're saying. I've edited my post so you can see what I'm on about.
    – Infiaria
    Commented Jun 9, 2018 at 15:40
  • Oh my god! This is super weird. I sincerely appreciate it!! I will try to use different complier, then.
    – KLee
    Commented Jun 9, 2018 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .