5

I would like to get the date(era) of this MWE

\documentclass{article}
\usepackage{filecontents}
\usepackage[
  backend=biber,
  style = archaeologie,
]{biblatex}
\addbibresource{\jobname.bib}
\begin{filecontents}{\jobname.bib}
  @book{de:re:publica,
    author  = {Cicero},
    title      = {De re publica},
    date     = {-0054/-0051},
  }
\end{filecontents}

\begin{document}
  \fullcite{de:re:publica}
\end{document}

enter image description here

as described in table 5 of the biblatex documentation:

enter image description here

How can I achieve tihs?

  • 2
    Option dateera=christian? – gusbrs Jun 9 '18 at 22:11
  • Are you sure you want Christian dates? – cfr Jun 9 '18 at 22:59
  • 1
    The style you are using prints the era string in some cases, but, in your example, using dateera-christian will produce '55-51' since both years are part of the same era. If the second was a common era year, you'd get '55 BC -51'. I assume you are using this style because you are publishing or hoping to publish in a journal which uses it. Is the style correct for those journals? – cfr Jun 9 '18 at 23:26
  • @cfr If I'm not mistaken, LukasCB is the developer/maintainer of the style. – gusbrs Jun 9 '18 at 23:36
  • 1
    LukasCB, as far as I was able to trace, the style sets the option alldates=comp. Using both dateera=christian and alldates=long would give you dateera information there. – gusbrs Jun 10 '18 at 0:33
5

The problem here is that english-archaeologie.lbx has \dateeraprint{#2} instead of \dateeraprint{#2year}. This is similar to issue #679 at the biblatex bug tracker. The code in english-archaeologie.lbx was based on an older version of the biblatex core macros from before the fix.

I have submitted a pull request (https://github.com/LukasCBossert/biblatex-archaeologie/pull/146) with the necessary changes.


I should probably add that all of this is under the assumption that you use

dateera=christian

or dateera=secular if you prefer the non-Christian denominations, as suggested by @gusbrs in the very first comment.

  • Ah! It was in the .lbx! (+1) – gusbrs Jun 10 '18 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.