1

I am trying to adjust my manuscript to Documenta style which can be found here (\documentclass[10pt,a4paper,twoside]{article}). Whenever I use the \qedhere-command at the end of an equation- or equation*-environment, I get the following warning:

Package amsthm Warning: The \qedhere command may not work correctly here on inp ut line XY.

In the initial version of my manuscpript in the amsart-documentclass, there was no similar warning.

In the output, I cannot see that the \qedhere-command does not work correctly. However, I would like to get rid of the warning. How I can get rid of this warning?

I think you can reproduce the effect when you load the above style and use \qedhere in an equation- or equation*-environment. It is therefore not necessary to provide a MWE.

Many thanks for your help. I would like to work through other warnings (e.g. overfull boxes) but this maybe useless amsthm-warning prevents from doing so in overleaf. I do not understand in the first place why it suddenly comes up.

Addendum. I load the following packages, in case it is relevant.

\usepackage{amssymb,amscd,amsthm,verbatim,amsmath,color,fancyhdr,mathrsfs}
\usepackage{graphicx}
\usepackage{turnstile}
\usepackage[disable]{todonotes}
\usepackage[bookmarks=true]{hyperref}
\usepackage{csquotes}

\def\tequiv{\ensuremath\sdststile{}{}}

\usepackage[letterpaper,left=2.5cm,right=2.5cm,top=2.5cm,bottom=2.5cm,dvips]{geometry}
  • 1
    Unrelated, but you shouldn't use amscd. The results are not very good. Use tikz-cd instead. – Bernard Jun 12 '18 at 17:04
4

As mentioned in another answer, amsthm should be loaded after amsmath. As described in a comment on that answer, this warning is produced when amsthm is incorrectly loaded before amsmath.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.