In using the package exercisebank, is it possible for "Exercise" header, "intro" material and "problem" numbers to start at the same column of the text? For example, the package prints

  • Exersise 1
  • ____Continuity of functions
  • ________(1a)......
  • ________(1b)......

I would prefer

  • Exersise 1
  • Continuity of functions
  • (1a)......
  • (1b)......

Thanks in advance

  • 1
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. Jun 12, 2018 at 20:42
  • Hello! I'm the author of exercisebank, and I've taken note of your request of use! To see how the margins are defined, you can check this file, which is a part of the exercisebank source! Don't hesitate to request features and report bugs at the issue tracker! Jun 17, 2018 at 8:10
  • ^ That is, you only need the top of said file. These lengths will be documented in an upcoming release :) Jun 17, 2018 at 8:22
  • Don't forget to upvote helpful answers and mark an answer as accepted if you find it sufficient to solve your problem! See [help/someone-answers]. Jun 22, 2018 at 13:11

2 Answers 2


Note that the exercisebank package is still in its alpha stage. This answer applies to version 0.1.4 (2018-04-28).

To align everything to the left, we have to align the labels of the itemize lists to the left and put some more space between labels and text. This can be achieved using the package enumitem and defining global settings.

Then, all the left and right margins the package sets to a certain value by default have to be re-set to zero.

Finally, some superfluous spaces occur around the word “Solution” that is used in the label for solutions. We need to redefine the underlying macro in order to remove these spaces that would disrupt the alignment.

Example file with problems and solutions:


Example main file:


\setlength{\pMarginLeft}{0pt}  % reset left margin to 0pt

\makeatletter                  % trim spaces around `Solution`
\gdef\@tr#1{\@ifundefined{@tr@#1}{#1}{\csname @tr@#1\endcsname}}

\usepackage{enumitem}          % define itemize settings




enter image description here

  • 1
    Seems like I've forgotten a percent-sign in the source which makes spaces around all translations. (The \@tr is a translation macro). Thank you for making me aware of this and I'll have it fixed shortly! For future convenience of making answers, the source can be found here. All of the source is in the src/ directory, but the readme is in the provided link. (Just for good measure; All internal macros will be prefixed with \exb@. That is: the \@tr will be renamed \exb@tr in the future to avoid clash) Jun 17, 2018 at 8:24

The answer by @JasperHabicht is completely correct for 0.1.4.

However, in the upcoming beta, 0.2.0, the margins have drastically changed. It is extremely likely that the margins won't change again, so at release you should check it out! If you then still want to remove margins, you can do

\exercisebanksetup{style margins=false}

Again this is for the upcoming version scheduled to be released around mid July.

If you update from 0.1.4 to 0.2.0, and it breaks your design, you can download the 0.1.4 release here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .