0

As stated in the title, my document compiles successfully with lualatex file.tex in the command line but not when in emacs using AUCTEX, executing C-c C-c. I'm using a Mac; Tex Live; and auctex v12.1.1.

I am aware of this answer: https://tex.stackexchange.com/a/21212/103829 and have inserted the following at the bottom of my .tex file:

%%% Local Variables: 
%%% coding: utf-8
%%% mode: latex
%%% TeX-engine: luatex
%%% End:
1

Your MWE is not like what you post, it contains:

%%% Local Variables: 
%%% coding: utf-8
%%% mode: latex
%%% TeX-engine: luatex
%%% TeX-master: ""
%%% End:

Remove the evil line with TeX-master. Or replace it with

%%% TeX-master: t

if needed.

Personnally I have had for decades

(setq TeX-one-master '"\"<none>\"")

in my .emacs to prevent AUCTeX modifying my file contents.

  • It could be that in the past AUCTeX did not have the default t setting for TeX-master which it seems to have now. I recall how painful it was at first when systematically my buffer ended up with some added lines for "Local Variables" at bottom, which got me really annoyed as I did not want to change modification date of a visited .tex file, typically. – user4686 Jun 14 '18 at 14:29
  • In my case I needed the %%% TeX-master: t for it to work. But I added (setq TeX-one-master '"\"<none>\"") to my .emacs file to prevent annoying additions to the bottom of files! – Oliver Angelil Jun 14 '18 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.