As title says, I was updating the packages in my TL installation (by tlmgr update --all) from the command line in Win7, but for some strange reason the computer just powered down during the update, and now after restarting it I can't get tlmgr to update anything (packages or itself by tlmgr update --self).

I can run the commands from the command line, but nothing happens. The command line window just stays black for a long time until the following line of text appears:

at C:/texlive/2011/tlpkg/TeXLive/TLPOBJ.pm line 108, <TMP> line 1.

After this appears, it returns back to the command line where I can type any new commands.

I assume this ends up in a reinstall of TL2011, but if someone have any suggestions for how I can try to fix this in order to avoid the reinstalling TL I'd be glad.

I also tried downloading the latest update of tlmgr from tug.org manually and install it, but didn't help.

Could it work to just replace the whole tl2011 install dir with one installation that got the exact same structure and file names from another computer (e.g. I have used C:\texlive\2011 on both computers)?

Below is a screen shot of the command line window (which basically gives me no leads).

screen shot of cmd window

  • 2
    I am guessing there are some temp files that need to be removed. From the <TMP> line 1 that is. Have you checked what C:/texlive/2011/tlpkg/TeXLive/TLPOBJ.pm actually says on line 108? Could you post it here? Feb 7, 2012 at 12:29
  • Content at line 108: $started || $cmd eq 'name' Otherwise, I tried copying the texlive installation from my laptop and just renaming the directories temporarily, and this seem to work OK (as for now), but if I could fix the other installation I'd prefer that.
    – blubbafett
    Feb 7, 2012 at 13:03
  • Ok, this is really not enough info, at least for me. There doesn't seem to be a real error, is there any message preceding the at ... part? Feb 7, 2012 at 14:10
  • Sorry for the late answer, completely forgot about this after I left work. As I wrote in my comment to the post below, I really don't have any other information as for now, or at least I don't know where to look for it in order to find out what what actually happened; that's the frustrating part.
    – blubbafett
    Feb 7, 2012 at 20:20

1 Answer 1


In such cases, the recommended way is to follow the "disater recovry" instructions from this page: http://tug.org/texlive/tlmgr.html which should fix your tlmgr. Once it works, you should run tlmgr check --files and reinstall packages with missing files (if any) using tlmgr install --reinstall broken1 broken2 .... You may then finish the updates with the usual tlmgr update --all.

If the "disaster recovery" instructions aren't enough to fix your tlmgr then I'm afraid there is nothing to do but to reinstall TeX Live.

Copying another installation from another computer may work if the machines and installation options are identical; on Unix it would be guaranteed to work, but on Windows there are also registry entries (file associations, uninstall entry, etc) about which I'm not entirely sure.

Anyway, if the disaster recovery procedure doesn't work, before you reinstall everything, I'd like to encourage you to post a detailed report with the exact error messages to help the TeX Live team understand what went wrong with the procedure and possibly make it more robust.

  • Thanks for your answer, and sorry for the late answer. I'll take a look at the "disaster recovery" when I'm back at work tomorrow. The problem is that I get no error message, nor any other message at all. When I type "tlmgr update --all" or any other command, all the text in the command window dissapears and the command window stays black/without text for ~2minutes, until the message I posted in my first question appears. Is there any other places that I can search for error messages? Any logs that I should/can check? Anywahs, I'll give the disaster recovery a try tomorrow.
    – blubbafett
    Feb 7, 2012 at 20:17
  • Seems like I have to reinstall, the disaster recovery doesn't work, and no matter what command I try to run I get the empty command line window, so I can't figure out what the error is. Anyways, thanks for taking your time to answer.
    – blubbafett
    Feb 8, 2012 at 7:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .