1

The vertical space that is created by the package is very big. I need to minimize it as much as possible. I need your help again.

I also have the following problem: After the change of the exercise file, the document is not compiled. What do I do afterwards? I change the size of the text in the documentclass (e.g. from 10pt to 11pt) and the document is compiled correctly. This problem started after the third exercise file added in the command: "\makeset{Set001}{ask40, ask41, ask42, ask43, ask44, ask46, ask48, ask49, ask50, ask51}"

My exercise file has the following structure:

\begin{intro}
  \begin{mdframed}
    \begin{center}
      50 - Απόδειξη της συνέχειας με υπόθεση συναρτησιακή σχέση
    \end{center}
  \end{mdframed}
\end{intro}
\begin{problem}
  Για τη συνάρτηση $ f $ ισχύει: \[ f(x+y)=f(x)+f(y) \] για κάθε $ x,y\in \mathbb{R} $. Να αποδειχτεί ότι:
  \begin{enumerate}
    \item Αν η $ f $ είναι συνεχής στο $ 0 $ θα είναι συνεχής στο $ \mathbb{R} $.
    \item Αν η $ f $ είναι συνεχής στο $ α\neq 0 $ θα είναι συνεχής στο $ \mathbb{R} $.
  \end{enumerate}
\end{problem}
\begin{problem}
  Για τη συνάρτηση $ f $ και για κάθε $ x,y>0 $ ισχύει η ισότητα \[ f(xy)=f(x)+f(y). \] Να δειχτεί ότι αν είναι συνεχής στο $ x=1 $ θα είναι συνεχής στο $ \mathbb{R}^*_+  $.
\end{problem}

My main file is the following:

\documentclass[a4paper,twocolumn,10pt]{article}

\usepackage{xltxtra}
%\usepackage{url}
\usepackage{xgreek}
\usepackage{graphicx}
\usepackage{amsmath, amsthm, amsfonts, amssymb}
\usepackage[total={18cm, 25.7cm}, left={1.5cm}, top={2cm}]{geometry}

 \usepackage{fancyhdr}
 \pagestyle{fancy}
 \lhead{Γεώργιος Χ. Δομουχτσής} \rhead{ΣΥΝΕΧΕΙΑ ΣΥΝΑΡΤΗΣΕΩΝ}
 \lfoot{} \cfoot{} \rfoot{\thepage}

\usepackage[math-style=ISO]{unicode-math}

\setmainfont{FreeSerif}
\setsansfont{FreeSans}
\setmonofont{FreeMono}

%\setmathfont[Scale=MatchUppercase]{Asana Math}
\setmathfont[Scale=MatchUppercase]{XITS Math}

\usepackage{mdframed}

 \usepackage{exercisebank}

\setlength{\pMarginLeft}{0pt}  % reset left margin to 0pt
\setlength{\ppMargin}{0pt}

\makeatletter                  % trim spaces around `Solution`
\gdef\@tr#1{\@ifundefined{@tr@#1}{#1}{\csname @tr@#1\endcsname}}
\makeatother

\usepackage{enumitem}          % define itemize settings
%\setlist[itemize]{align=left,leftmargin=6em,labelwidth=5em,labelsep=1em}
\setlist[itemize]{align=left,leftmargin=1cm,labelwidth=1cm,labelsep=0cm}
\setlist[enumerate]{align=left, leftmargin=0.5cm, labelwidth=0.5cm, labelsep=0cm}

\exercisebanksetup{exercise directory=/home/geodom61/0XeLaTeX16GB/PD_SYNEXEIA/, figure root directory=/home/geodom61/0XeLaTeX16GB/PD_SYNEXEIA/FIG/}

\makeset{Set001}{ask40, ask41, ask42, ask43, ask44, ask46, ask48, ask49, ask50, ask51}

 \translateExBank{Problem=Άσκηση, Solution=Λύση}
%
% %\DisplaySolutions

\title{\textbf{Ασκήσεις στη ΣΥΝΕΧΕΙΑ ΣΥΝΑΡΤΗΣΕΩΝ}}
\author{Γεώργιος Χ. Δομουχτσής  \thanks{Οι σημειώσεις αυτές είναι ουσιαστικά η δουλειά του Δημητρίου Α. Παπακωνσταντίνου, Σχολικού Συμβούλου Μαθηματικών}}

\date{\today}



\begin{document}
\begin{titlepage}
\maketitle
\end{titlepage}

\buildset{Set001}
\end{document}

Finally, I send you the 2nd page of my document:

enter image description here

0

Note that the exercisebank package is in its (late) alpha stage. This answer applies to version 0.1.4 (2018-04-28).


The vertical space that is created by the package is very big. I need to minimize it as much as possible.

Exercisebank has very many vertical spaces, and I'm not really sure which one you want to remove.

Firstly, the package makes sure, by default, that all text accompanying a part problem stays on one page and similarly for solutions. This does create quite a bit unnecessary vertical space.

To disable this behaviour, you can do

\exercisebanksetup{tighten paragraphs=Off}

If you want to further decrease the vertical space you can look at the default lengths in exercisebank. However, these are not documented (yet, but will be in next version). The lengths that are affecting vertical space, with their default values, are:

\setlength{\pMarginBelow}{1em}  % Space below a problem ("file")
\setlength{\pMarginAbove}{1em}  % Space above a problem ("file")
\setlength{\ppMarginBelow}{2em} % Space below a part problem (the problem-environment)
\setlength{\ppMarginAbove}{2em} % Space above a part problem (the problem-environment)

You could set all of these to 0em and that will remove more vertical space.

After the change of the exercise file, the document is not compiled.

You should provide the error messages! What did you change?

I change the size of the text in the documentclass (e.g. from 10pt to 11pt) and the document is compiled correctly.

There is nothing I can think of in the source of exercisebank that should have any influence on font size. Most likely, this error is due to something inside the ask43-file or perhaps ask42-file.

However, it might be caused by having very big problem-environments in combination with the paragraph tightening feature. If this is the case, it should be solved by using the above tighten paragraphs=Off.


On a different note

I haven't really tested the package with the twocolumn, and this might be a source to many weird behaviours. If you just want to show all exercises you can do \sprite instead of \buildset.

Also, there is one command, \squeeze, that will really squeeze everything down, but I suspect it might be a bit much.

|improve this answer|||||
  • Simple changes in exercise files (or adding a new exercise file in \buildset command) and compilation presents the previous pdf file without error messages. If I delete the pdf file (or change the letter size), compilation produces the correct pdf. – George Domus Jun 22 '18 at 21:00
  • Doesn't really help. I strongly suspect that error is in one of the files, and not in exercisebank. – Andreas Storvik Strauman Jun 22 '18 at 21:59
  • The vertical space between part problems changes when I change the \pMarginAbove and not the \ppMarginAbove! – George Domus Jun 24 '18 at 19:05
  • Try downloading this prerelease and see if it helps? (Just put the exercisebank.sty into your project working directory) – Andreas Storvik Strauman Jun 24 '18 at 22:09
  • I installed the prerelease and the vertical spacing is OK. The problem is that the labels of the part problems are outside(in front of) the text column. How can I correct the command "\setlist[itemize]{align=left,leftmargin=2cm,labelwidth=1cm,labelsep=1cm}" in order to solve this problem. I shall continue to use the prerelease. – George Domus Jun 26 '18 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.