4

I have observed that various horizontal and vertical lines look ugly on arXiv (and elsewhere). This includes \overline, \hrule, fraction line, end-of-proof square, lines drawn by xy-pic but not those drawn by tikz. It also does not affect the absolute value vertical brackets. The effect is that the line slightly thicker, maybe slightly misplaced, and rendered in a way that when zooming, the thickness sometimes appears even thicker and sometimes not. This last effect won't affect printing, but looks ugly on display.

The effect is apparent for example in arXiv:1705.07399 in the diagram on page 2: when zoomed in, the leftmost arrow is thicker than the curves forming the arrow tip, it is not centered, and its ends are rectangular rather than round.

I have found out that this happens when the source is compiled via latex → dvips → ps2pdf rather than pdflatex.

Do you know more about this issue? Can it be somehow fixed even when using dvi and ps in between?

Updated: I have added some screenshots. The first pair is produced by latex → dvips → ps2pdf. Note also the ugly fraction bars in the text. Of cource the effect is strengthened by “interference with zooming”, but the big arrow to the right shows that the effect is really present.

An ugly diagram An ugly arrow

The following is produced by pdflatex.

A nice diagram A nice arrow

3
  • 1
    Can you post a screenshot and tell us, which pdf viewer you are using? – DG' Jun 21 '18 at 11:46
  • Exactly where on that arxiv article? I find no strangeness on page 2 when using the PDF viewer in Firefox of Linux. Lines looking strange on screen is well known due to rounding errors when displaying on screen, they may appear at certain resolutions and not at others. – daleif Jun 21 '18 at 11:55
  • Of course viewer or resolution may affect how much the issue is apparent, but the point is the lines are really a bit thicker and uglier. I'll add some screenshots. Also look at @egreg 's screenshots. – user87690 Jun 22 '18 at 16:37
5

On the left is what I see at maximum magnification and it's really awful; on the right the result by compiling with pdflatex

enter image description here enter image description here

The output is slightly better. You can fix the issue by explicitly loading the dvips driver:

\usepackage[all,dvips]{xy}

Then the arrow becomes

enter image description here

The whole diagram

enter image description here

2
  • Thank you for the answer and the screenshots. This fixes the problem with the diagram (I wonder whether XYpic can automaticaly choose the rigth driver; now the source depends on the latex compiler). Do you have any idea how to solve it elsewhere or why it occurs in the first place? – user87690 Jun 22 '18 at 16:22
  • @user87690 Sorry, no idea. You can use ifpdf. – egreg Jun 22 '18 at 16:24
2

I had the same problem. Adding \pdfoutput=1 on the second line of my main tex file solved the problem. Arvix's default engine isn't pdflatex, this line forces arvix to use pdflatex.

1
  • Yes, I actually know for some time that \pdfoutput=1 fixes the problem on arXiv, but I forgot to update this question. Thank you for bringing it up. – user87690 Dec 18 '20 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.