1

I have some problems with these packages; if anyone of you could help me I would really appreciate.

Here's my code:

\documentclass[ignorenonframetext,fleqn]{beamer}
\usepackage[english]{babel}
\usepackage[T1]{fontenc}
\usepackage{lxfonts}
\usepackage{amsmath,%amsfonts,amssymb} 
\usepackage{xcolor, colortbl}% <-----------------------
\usetheme{dresden}
\usepackage{etoolbox}

\usepackage[beamer,customcolors,shade]{hf-tikz}
\usepackage{ctable}% 
\listfiles
\tikzset{set fill color=red!30,set border color=red}
\begin{document}
\begin{frame}{\textcolor{white}{Overeducation and the GPG}}
Mincer wage equation: 
\begin{equation*}\notag
\ln{W_i}={{X_i}^{'}}\beta+\gamma{Overeducation}+\epsilon_i
\end{equation*}
Oaxaca-Blinder decomposition:
\begin{align*}
z+t&=\tikzmarkin<2>{a}{vshade}[x+y]\tikzmarkend{a}{vshade}\\ 
\end{align*}
\end{frame}
\begin{frame}
\begin{tikzpicture}
 \draw [->](-2,0) -- (2,0);
\filldraw [black] (0,0) circle (2pt) node[anchor=north] {May 20,2014};
 \end{tikzpicture} 
\end{frame}
\end{document}`

In the first slide, I do not understand why the option 'shade' does not work..

In the second slide, instead, I would like to write a number over the line , which should be some 0 before the date and some 1 after. I would like the number to shift from left to right transforming from 0 to 1..

Does anyone know how I could do it? Thanks a lot! :) Giulia

1

There were a few errors. Dresden instead of dresden, a % before amsfonts and \tikzmarkin takes only one argument.

\documentclass[ignorenonframetext,fleqn]{beamer}
\usepackage[english]{babel}
\usepackage[T1]{fontenc}
\usepackage{lxfonts}
\usepackage{amsmath,amsfonts,amssymb} 
\usepackage{xcolor, colortbl}% <-----------------------
\usetheme{Dresden}
\usepackage{etoolbox}

\usepackage[beamer,customcolors,shade]{hf-tikz}
\usepackage{ctable}% 
\listfiles
\tikzset{set fill color=red!30,set border color=red}
\begin{document}
\begin{frame}{\textcolor{white}{Overeducation and the GPG}}
Mincer wage equation: 
\begin{equation*}\notag
\ln{W_i}={{X_i}^{'}}\beta+\gamma{Overeducation}+\epsilon_i
\end{equation*}
Oaxaca-Blinder decomposition:
\begin{align*}
 z+t&=\tikzmarkin<2>[top color=white, bottom color=blue!20]{a}
[x+y]\tikzmarkend{a}\\ 
\end{align*}
\end{frame}
\begin{frame}
\begin{tikzpicture}
\node (date) {May 20,2014};
\draw[->] ([xshift=-1cm,yshift=1mm]date.north west) --
([xshift=1cm,yshift=1mm]date.north east) coordinate[midway] (X);
\filldraw [black] (X) circle (2pt)  node[above]{some number};
 \end{tikzpicture} 
\end{frame}
\end{document}

enter image description here

enter image description here

  • Thanks for the reply. However, the problem was not present without the option 'vshade'.. I mean, I obtained the same as you obtained by keeping away 'vshade' from the \tikmarzin.. the point is that I was wonderind why tho option 'shade' and writing 'vshade' as suggested in the guide of the package does not work and gives me an error.. – giulia Jun 22 '18 at 17:41
  • @giulia I think you are mistaken in your interpretation what vshade in \tikzmarkin[top color=white, bottom color=blue!20]{vshade} x+y=400 \tikzmarkend{vshade} of the example does. vshade is just a name of a label, which you could also call cutefurryrodent, say. In particular, \tikzmarkin has one optional and one mandatory arguments, but you were trying to add another mandatory argument. So you can keep either a or vshade, but not both. – marmot Jun 22 '18 at 17:54
  • Ahh ok I understand what you mean, thanks a lot. however, even if I keep only 'vshade' as mandatory argument and not 'a' ,the shadings that should appear according to the example do not appear in my case.. maybe I am making some mistakes.. however, it was just a curiosity :) Do you know the package I need to do the second request? it would be fantastic.. thanks however, your help was really appreciated :) – giulia Jun 22 '18 at 20:14
  • 1
    @giulia The shading is controlled by the optional argument [top color=white, bottom color=blue!20], so I added that. I also added a proposal for the line. If you want it shorter, just adjust the xshift directives, i.e. make them smaller. – marmot Jun 22 '18 at 20:23
  • God yees obviouslyyyy it was the one in the square bracketss :o sorry for that.. and thanks againnn! – giulia Jun 22 '18 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.