14

I just installed Kile on Ubuntu and I can't get it to work.

Even just starting with one of the templates I continue to get the error:

[PDFLaTeX]finished with exit code 1
/usr/share/texmf-texlive/tex/latex/base/input.sty:131:File 'utf8x.def not found.\endinput

I have spent quite a while trying to figure this out...

17

You can install the Package texlive-latex-extra. That should resolve the problem.

This seems to be a bug in Ubuntu which does not pull in this packet when installing Kile.

  • This bug has been fixed in Ubuntu 12.04. – lanoxx May 22 '12 at 14:33
7

\usepackage[utf8x]{inputenc} will not work any longer on Ubuntu/Kile. I had the same problem as I updated from 10.04 to 11.11.

Now you simply have to use:

\usepackage[utf8]{inputenc}

Just remove the x from utf8x.

  • \usepackage[utf8]{inputenc} really works. I was getting the error finished with exit code 1 and was not compiling. Now it is giving finished with exit code 2 but the document is compiling. – user31129 Jun 29 '13 at 10:12
1

Well, without seeing your doc, it is hard to to know what is wrong. Does this test work:

\documentclass{article}
\begin{document}
Hello world
\end{document}

if it works, something else is wrong and we'd like to see your doc or a minimal example showing your problem.

I do not thing utf8x and ucs is recommended any more.

BTW: Which TeX Live installation are you using, the Ubuntu one or the one from TUG?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.