1

I recently upgraded from Texlive 2017 to Texlive 2018 by default through dnf on a fedora 28 system, using Kile as the front end. My tex installation now fails to produce anything. I have removed texlive 2016 and uninstalled and reinstalled the 2018 version with no joy. On using Kile, my output gives me

*****
*****     PDFLaTeX output: 
*****     cd "/home/<username>/work/science/chemistry/mod_io_mat"
*****     pdflatex -shell-escape
*****

This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017) (preloaded format=pdflatex)
 \write18 enabled.

I'm at a loss and under some time pressure....

closed as off-topic by user36296, Stefan Pinnow, Troy, Phelype Oleinik, Sebastiano Aug 14 '18 at 19:05

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    What happens when you run pdfLaTeX from the terminal? – Joseph Wright Jun 25 '18 at 8:55
  • 2
    you said you have installed texlive 2018 but the log you show is texlive 2017. – David Carlisle Jun 25 '18 at 9:55
  • 1
    check in Kile where Settings->ConfigureKile->Tools->Build->LaTeX is pointing to, as soon as you have the time. – naphaneal Jun 25 '18 at 10:53
  • 4
    I'm voting to close this question as solved by the OP – user36296 Aug 14 '18 at 17:01
  • 1
    Just to add to the soup of comments: This is a bug in Kile. It should fetch the paths to the executables from the current $PATH, but it doesn't. A few days ago I was doing the same and found the bug report somewhere. I worked around the issue by hardcoding the path of the TL2018 executables in Settings->Configure Kile->Tools->Build. Definitely not pretty, but it will work until 2019. – Phelype Oleinik Aug 14 '18 at 17:07