I tried to compile the following using the beamer class:

    $$T(\mathcal{P})=\mathbb{R}$$  and 
 $$\mathrm{M}(\mathcal{P})=\mathbb{R}_{+}^{3}/ \mathrm{S}_3$$

If I complie the math stuff alone, it works just fine, but when I put them inside a block environment, it says missing $ inserted.

What should I do?


The block-environment needs a title:

Your Text

you can get rid of the title for example if you use a space:

\begin{block}{\ }

At least, this solved your problem on my slides

  • Thanks! I totally forgot that. In fact puting {} did the job. – yaa09d Feb 8 '12 at 8:16
  • 2
    ... and so if you don't supply a title, it grabs the next token as one which, in this case, is $, and this causes it to get very confused. Note that there is a difference between {\ } and {} since {\ } specifies a title which happens to be a space but {} says "There's no title" and beamer treats the two differently. – Loop Space Feb 8 '12 at 14:09
  • that ist true, the option with {\ } adds a little space above the content inside the block environment, which is kind of nice in my opinion – Matz Feb 8 '12 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.