3

My problem is that the "year" field in my biblatex library is not filled it; instead, the "date" field is, but it includes month and day besides year. \usepackage[backend=biber, style=apa]{biblatex} then prints day and month, although this is not allowed under APA. I tried \AtEveryBibitem{\clearfield{month}} which of course clears the wrong field. How can I remove month and day from the bibliography?

A biblatex entry looks like this:

@Article{breiman_random_2001,
  author       = {Breiman, Leo},
  title        = {Random Forests},
  volume       = {45},
  number       = {1},
  pages        = {5--32},
  issn         = {0885-6125, 1573-0565},
  date         = {2001-10-01},
  doi          = {10.1023/A:1010933404324},
  file         = {Full Text,
  journaltitle = {Machine Learning},
  langid       = {english},
  shortjournal = {Machine Learning},
  url          = {https://link.springer.com/article/10.1023/A:1010933404324},
  urldate      = {2018-04-17},
}

My reproducible latex code looks like this:

\documentclass[11pt, a4paper]{article}
\usepackage[backend=biber, style=apa]{biblatex} %sorting=nyt, 
\bibliography{breiman}
\AtEveryBibitem{
    \clearfield{month}
    \clearfield{doi}
    \clearfield{url}
    \clearfield{note}
    \clearfield{chapter}  
    \clearfield{date}  
}
\DeclareLanguageMapping{english}{english-apa}

\begin{document}
    Random forests are cool \parencite{breiman_random_2001}.
    \printbibliography  
\end{document}

The result looks like this:

enter image description here

  • How about option date=year? – gusbrs Jun 27 '18 at 15:06
  • @gusbrs Not working.. – tomka Jun 27 '18 at 15:07
  • Mmh... Well, from the documentation of biblatex-apa: "The APA style dictates long date formats". Perhaps that's why biblatex does not respond to this option for apa. – gusbrs Jun 27 '18 at 15:16
  • 2
    APA style requires full dates in some cases (newspaper articles, certain online sources come to mind, ...), so you can not unequivocally say that full dates are wrong according to APA style. biblatex-apa does not automatically determine if the full date is appropriate or not and always shows the full date, the user will have to make sure that full dates only appear in the source if appropriate or take other measures to prevent unwanted full dates. I agree that in this case the full date is not called for and read the APA style in a way that it wants only the year in this case. – moewe Jun 27 '18 at 20:12
  • @moewe manual editing of the bib file seems extremly cumbersome. To my knowledge (which is a bit outdated; long time since I learnt APA format in college) APA does not require detailed date for academic journals, only for popular new sources, e.g. newspapers, mainstream journals etc. – tomka Jun 27 '18 at 20:19
4

Adding labeldate=year to the package options works. Also suppressing the DOI and URL fields can also be done as a package option.

\begin{filecontents}{\jobname.bib}
@Article{breiman_random_2001,
  author       = {Breiman, Leo},
  title        = {Random Forests},
  volume       = {45},
  number       = {1},
  pages        = {5--32},
  issn         = {0885-6125, 1573-0565},
  date         = {2001-10-01},
  doi          = {10.1023/A:1010933404324},
  file         = {Full Text},
  journaltitle = {Machine Learning},
  langid       = {english},
  shortjournal = {Machine Learning},
  url          = {https://link.springer.com/article/10.1023/A:1010933404324},
  urldate      = {2018-04-17},
}
\end{filecontents}

\documentclass[11pt, a4paper]{article}
\usepackage[backend=biber, style=apa,labeldate=year,doi=false,eprint=false]{biblatex} %sorting=nyt, 
\addbibresource{\jobname.bib}

\DeclareLanguageMapping{english}{english-apa}

\begin{document}
    Random forests are cool \parencite{breiman_random_2001}.
    \printbibliography  
\end{document}

output of code

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.