2

I would like to use the tbtags option with amsmath multiline equations in beamer. Unfortunately, I cannot get it to work. Here is a minimal example that works using article, but does not work with beamer.

\documentclass[amsmath={tbtags}]{beamer}
\begin{document}
\begin{equation}
    \begin{split}
        M &= \text{first line} \\ &\qquad \text{second line}
    \end{split}
\end{equation}
\end{document}

I can't find anything in the beamer docs indicating that this should not work. What am I doing wrong?

2

Using the noamsthm option, beamer does not load amsmath by default and you can load it with whatever options you like.

\documentclass[noamsthm]{beamer}

\usepackage[tbtags]{amsmath}

\begin{document}
\begin{equation}
    \begin{split}
        M &= \text{first line} \\ &\qquad \text{second line}
    \end{split}
\end{equation}
\end{document}

enter image description here

  • That did it! Thank you! By the way, beamer does load amsmath. :-) – Gary L. Gray Jun 28 '18 at 19:52
  • 1
    @GaryL.Gray Beamer only loads amsmath if the option noamsthm is not given, see user guide p. 121 – samcarter_is_at_topanswers.xyz Jun 28 '18 at 19:55
1

you can your write mwe correctly as follows:

\documentclass[tbtags]{beamer}

\begin{document}
\begin{frame}
\begin{equation}
    \begin{split}
        M &= \text{first line} \\ &\qquad \text{second line}
    \end{split}
\end{equation}
\end{frame}
\end{document}

enter image description here

  • @samcarter, indeed. number is not positioned correctly. i will correct my answer accordingly asap. – Zarko Jun 28 '18 at 20:52
  • 1
    The difference is really hard to see. When I first saw this questions I was wondering what the problem is because the code compiled just fine :) – samcarter_is_at_topanswers.xyz Jun 28 '18 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.