1

I'm creating my thesis in LaTeX and it's the first time I use it. As a template I'm using that of Tufte.

I have a bibliography and I would also like to create a sitography separate from the bibliography (on another page).

This is a piece of my code:

\documentclass{tufte-book}

\begin{document}
Lorem ipsum \cite{ColinWare_InformationVisualization}, \cite{BenShneiderman_TheEyesHaveIt}, \cite{UsabilityFirst}.

\backmatter
\bibliography{./bib/bibliography}
\bibliographystyle{plainnat}
\bibliographystyle{plainnat}

\end{document}

and bibliography.bib is:

@book{ColinWare_InformationVisualization,
    author = {Colin Ware},
    title = {Information visualization: perception for design},
    year = {2012},
    publisher = {Morgan Kaufmann},
    edition = {Third},
    isbn = {978-0123814647}
}

@report{BenShneiderman_TheEyesHaveIt,
    author = {Ben Shneiderman},
    title = {The eyes have it: a task by data type taxonomy for information visualizations},
    year = {1996}
}

@misc{UsabilityFirst,
    title = {{Usability first} Scientifi visualization definition},
    howpublished = {\url{http://www.usabilityfirst.com/glossary/scientific-visualization/}}
}

I want to separate misc elements to report and book elements. report and book elements should be in a section called Bibliography, misc elements should be in a section called Sitography.


\usepackage[backend=biber, style=numeric, defernumbers]{biblatex}

\begin{document}

\backmatter
%\bibliography{./bibliografia/bibliography}
%\bibliography{./bibliografia/sitography}
\printbibliography[nottype=online, heading=subbibliography, title=Bibliography]
\printbibliography[type=online, heading=subbibliography, title=Sitography]
\bibliographystyle{plainnat}

Errors:

enter image description here


We are almost there. Here's what I got:

enter image description here

Why in brackets there are no numbers but the letter o? Why is the title not formatted as if it were the title of a chapter?

Thene elements of type booklet, misc and online are not printed..

@misc{GleamArt,
    ALTauthor = {Wouter Van den Broeck, Corrado Gioannini, Bruno Gonçalves, Marco Quaggiotto, Vittoria Colizza, Alessandro Vespignani},
    title = {The GLEAMviz computational tool, a publicly available software to explore realistic epidemic spreading scenarios at the global scale},
    date = {2011},
    OPTurl = {https://bmcinfectdis.biomedcentral.com/articles/10.1186/1471-2334-11-37}
}
@online{UsabilityFirst,
    ALTauthor = {},
    title = {Usability first: scientific visualization definition},
    date = {2011},
    url = {http://www.usabilityfirst.com/glossary/scientific-visualization/}
}
5

1 Answer 1

4

With biblatex you could try something like this.

Note that the filecontents bit is only to make the example self-contained. In your real document you will have a normal .bib file.

The tufte-book class normally loads natbib, so we explicitly tell it that we want to take over full control over which package we load by passing the nobib option to the document class. (You get errors if you don't do that since natbib and biblatex are incompatible.)

\documentclass[nobib]{tufte-book}
\usepackage[backend=biber, style=numeric, defernumbers]{biblatex}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{ColinWare_InformationVisualization,
  author    = {Colin Ware},
  title     = {Information visualization: perception for design},
  year      = {2012},
  publisher = {Morgan Kaufmann},
  edition   = {3},
  isbn      = {978-0123814647}
}
@report{BenShneiderman_TheEyesHaveIt,
  author = {Ben Shneiderman},
  title  = {The eyes have it: a task by data type taxonomy for information visualizations},
  year   = {1996}
}
@online{UsabilityFirst,
  title = {{Usability first} Scientific visualization definition},
  url   = {http://www.usabilityfirst.com/glossary/scientific-visualization/},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}
Lorem ipsum \cite{ColinWare_InformationVisualization,BenShneiderman_TheEyesHaveIt,UsabilityFirst}.

\backmatter
\printbibliography[nottype=online, heading=subbibliography, title=Bibliography]
\printbibliography[type=online, heading=subbibliography, title=Sitography]
\end{document}

enter image description here

I made the online source an @online entry, but you can do the same thing with @misc if you prefer that.

Note that you will have to run Biber instead of BibTeX, see Biblatex with Biber: Configuring my editor to avoid undefined citations, and that in general you are now using biblatex and not natbib any more, so you might want to read bibtex vs. biber and biblatex vs. natbib and What to do to switch to biblatex?.

9
  • Thank you so much but I can not compile the file. I modified my file adding \usepackage[backend=biber, style=numeric, defernumbers]{biblatex}, I removed \bibliography{./bibliografia/bibliography} and added \printbibliography[nottype=online, heading=subbibliography, title=Bibliography], \printbibliography[type=online, heading=subbibliography, title=Sitography] (see the modified code in the main message). Then on TeXstudio I chose Bibliography --> type: BibTeX. Compiling I get some errors. Commented Jul 2, 2018 at 16:10
  • @jennifer You need to add the option nobib to your document class. And you also need to configure your system for Biber see the last two links in my answer.
    – moewe
    Commented Jul 2, 2018 at 16:17
  • @jennifer Additionally you should also remove the \bibliographystyle{plainnat} and you should delete the temporary .aux, .bbl, .blg files in your working directory.
    – moewe
    Commented Jul 2, 2018 at 16:30
  • Ok, one last thing: how do I insert the path of the files for the bibliography and the sitography? I removed the code related to the filecontents, and I have the two files bibliography.bib and sitography.bib but I do not know how to include them. In fact now, thanks to your advice, the code compiles but does not appear neither the bibliography nor the sitography. Commented Jul 3, 2018 at 6:22
  • @jennifer I have added another link to my answer that explains this in more detail. Basically you just need \addbibresource{bibliography.bib} and \addbibresource{sitography.bib} where my example has the filecontents stuff and \addbibresource{\jobname.bib}.
    – moewe
    Commented Jul 3, 2018 at 6:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .