1

I want to use the fontawesome icons in my document. After trying around a little i got to the following code:

% !TeX program = xelatex
\documentclass[a4paper,12pt]{article}

\usepackage{fontspec}
\usepackage{fontawesome}

\begin{document}

\faTwitter

\end{document}

The code is compiling and no error is shown, sadly there is no "twitter-icon", but just a grey square displayed, so it looks like the icon would not be found. Did I forget to do something?

  • Possibly there is some more information in the .log file. Look for the line starting with 'Package: fontawesome' and below. If you can't find anything yoursefl, then you can add the contents of (that part of) the log file to your question. – Marijn Jul 3 '18 at 11:09
  • Do you have the actual FontAwesome font installed? (It doesn't need to be installed with PDFLaTeX but is required for XeLaTeX.) If not, then this may be a duplicate of FontAwesome font not found? – Nicola Talbot Jul 3 '18 at 11:15
  • I'm not sure wether they are really installed. I used to try this but that did not work out either. Can I conform if the right fontawesome is installed? – Rüdiger Jul 3 '18 at 12:01
  • One way to check if the font is installed is to open a word processor (Microsoft Word, LibreOffice Writer, etc.) and see if the font is in the list. – Marijn Jul 3 '18 at 13:31
  • If the font isn't installed (or if it's installed but isn't found) there should be an error message from fontspec in the .log file. – Nicola Talbot Jul 3 '18 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.