0

I have an issue with biber, up until now citations worked fine, in that once >2 authors were in the citation it truncated the list to "smith et al" . However just the other day for some citations this changed, and i don't understand why.

I have tried the previously mentioned method of {} names in the .bib file, but that results in both first and last names being written eg. "smith, allison et al." I also tried adding the bibtex again, to no avail as well as changing maxcitenames in the preamble.

  \documentclass[titlepage, a4paper,12pt, oneside, bibliography=totoc]{scrartcl}
\usepackage[
backend=biber,
style=authoryear-comp,      
hyperref=true, 
isbn=false,
doi=false,
url=false,
natbib=true,
dashed=true, 
sortlocale=auto, 
maxcitenames=1, 
mincitenames=1, 
maxbibnames=7, 
minbibnames=4,
giveninits=true, 
uniquename=false 
]{biblatex}

\addbibresource{citations.bib}
\defbibheading{bibintoc}[\bibname]{References} 
\usepackage{textcomp}
\usepackage{prettyref}

\begin{document}
\citep{Heidemann2014b}
\end{document}

here are examples of my .bib entries where the program struggles:

@article{Heidemann2014b,
abstract = {Nematodes are the most abundant invertebrates in soils and are key prey in soil food webs. Uncovering their contribution to predator nutrition is essential for understanding the structure of soil food webs and the way energy channels through soil systems. Molecular gut content analysis of consumers of nematodes, such as soil microarthropods, using specific DNA markers is a novel approach for studying predator–prey interactions in soil. We designed new specific primer pairs (partial 18S rDNA) for individual soil-living bacterial-feeding nematode taxa (Acrobeloides buetschlii, Panagrellus redivivus, Plectus velox and Plectus minimus). Primer specificity was tested against more than 100 non-target soil organisms. Further, we determined how long nematode DNA can be traced in the gut of predators. Potential predators were identified in laboratory experiments including nine soil mite (Oribatida, Gamasina and Uropodina) and ten springtail species (Collembola). Finally, the approach was tested under field conditions by analyzing five mite and three collembola species for feeding on the three target nematode species. The results proved the three primer sets to specifically amplify DNA of the respective nematode taxa. Detection time of nematode DNA in predators varied with time of prey exposure. Further, consumption of nematodes in the laboratory varied with microarthropod species. Our field study is the first definitive proof that free-living nematodes are important prey for a wide range of soil microarthropods including those commonly regarded as detritivores. Overall, the results highlight the eminent role of nematodes as prey in soil food webs and for channelling bacterial carbon to higher trophic levels.},
author = {Heidemann, Kerstin and Hennies, Annika and Schakowske, Johanna and Blumenberg, Lars and Ruess, Liliane and Scheu, Stefan and Maraun, Mark},
doi = {10.1111/j.1600-0706.2013.00872.x},
file = {:C$\backslash$:/Users/Maria Rinke/Desktop/kerstin Literatur/Free living nematodes -2014-Oikos.pdf:pdf},
isbn = {1600-0706},
issn = {16000706},
journal = {Oikos},
number = {10},
pages = {1199--1211},
title = {{Free-living nematodes as prey for higher trophic levels of forest soil food webs}},
volume = {123},
year = {2014}
}

the citation I get from this looks like this: "Heidemann, Hennies et al., 2014"

  • 2
    For now my best guess is that you want uniquelist=false, see Set limit to one author when using “et al.” in biblatex. If you have problems with first names appearing, see also Literature with Biber generates strange citations: firstnames appear erratically – moewe Jul 6 '18 at 11:06
  • 1
    You are also missing a comma after the polyglossia option, which is not recognised by biblatex and would throw an error (this could be a problem here, because the option that follows it is maxcitenames=1 and it could be affected by that). Remove the line containing polyglossia in the biblatex options. Additionally sortlocale=auto, is the default and usually you should not have to set it to a different value. dashed=true, is also the default. – moewe Jul 6 '18 at 11:11
  • 1
    hyperref=true is usually not better than the default hyperref=auto, both settings enable hyperlinks if and only if the hyperref package is loaded; the difference being that true warns if the hyperref package is not loaded. – moewe Jul 6 '18 at 11:11
  • 2
    Off-topic, but hyperref should be loaded as one of the last packages – user36296 Jul 6 '18 at 11:17
  • 1
    Remove the braces around {Hennies, Annika} etc. And remove the polyglossia line. Unfortunately, this is still not an MWE we could test, so that is all I can say. – moewe Jul 6 '18 at 13:39
3

The code in https://tex.stackexchange.com/revisions/439513/4 shows two problems

  1. The option polyglossia is unknown and is missing comma.

    \usepackage[
    backend=biber,
    style=authoryear-comp,      
    hyperref=true, 
    isbn=false,
    doi=false,
    url=false,
    natbib=true,
    dashed=true, 
    sortlocale=auto, 
    polyglossia
    maxcitenames=1, 
    mincitenames=1, 
    maxbibnames=7, 
    minbibnames=4,
    giveninits=true, 
    uniquename=false 
    ]{biblatex}
    

    biblatex does not know a polyglossia option and even if it were an option it is missing the comma at the end. This causes biblatex to look for an option polyglossiamaxcitenames that does not exist. In particular that means that maxcitenames=1 is ignored.

  2. Unnecessary braces around author names.

    @article{Heidemann2014b,
      author = {Heidemann, Kerstin and {Hennies, Annika} and {Schakowske, Johanna} and {Blumenberg, Lars} and {Ruess, Liliane} and {Scheu, Stefan} and {Maraun, Mark}},
      doi = {10.1111/j.1600-0706.2013.00872.x},
      isbn = {1600-0706},
      issn = {16000706},
      journal = {Oikos},
      number = {10},
      pages = {1199--1211},
      title = {{Free-living nematodes as prey for higher trophic levels of forest soil food webs}},
      volume = {123},
      year = {2014}
    }
    

    This will cause biblatex to treat the names as a unit "Hennies, Annika" instead of a name consisting of the given name Annika and the family name Hennies.

Together these two effects cause part of what you were seeing.

If you still get

Heidemann, Hennies et al., 2014

from the example entry, then you must cite a different source with the same lead author (Kerstin Heidemann) and different co-authors. biblatex adds more names in that case to distinguish the different lists of authors. If you don't want that, you need the option

uniquelist=false

See also Set limit to one author when using "et al." in biblatex.

  • Hi, thanks for the help, I have removed the code and amended the .bib file. Now it is better but still cites like so "Heidemann, Hennies et al. 2014". It is strange, because it only does it for certain citations, I'll have a look if there is a pattern. – Maria Jul 6 '18 at 14:34
  • @Maria See the last link in my answer: tex.stackexchange.com/q/69028/35864 You probably want uniquelist=false. If you run only the code from the MWE you will find that it does produce "Heidemann et al. 2014", so the example is not complete. – moewe Jul 6 '18 at 14:37
  • Perfect! thanks a lot, and I am sorry about the bother, LaTex newbie over here :-D – Maria Jul 6 '18 at 14:45
  • @Maria It's OK. Just try to make your examples as minimal as possible in the future and double-check that they show the problem you are having (ideally by running it in a new, empty directory). That makes it much easier to help you. – moewe Jul 6 '18 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.