0

Gummi is a fantastic live preview TeX editor. The problem I am facing with Gummi is that even if I install TeX Live 2018 separately using install-tl from the install-tl-unx.tar.gz file, I still have to install old texlive dependencies that come with gummi using apt install and Gummi only uses those (2017 version).

Is there a way to make it point to TeX Live 2018 ?

I am using Ubuntu 18.04 bionic.

1

Just after I posted the question I found a simple work around.

First I installed TeX Live 2018 with install-tl from the install-tl-unx.tar.gz file using this Guide. Follow the post-install checks mentioned in the guide.

Install Gummi with sudo apt install gummi

Manually remove TeX Live 2017 dependencies installed with gummi using

  1. apt remove texlive-base
  2. apt remove texlive-binaries

If your PATH variable properly points to TeX Live 2018, Gummi should detect and use it automatically.

Update 1: The proper solution as pointed out by @daleif is to use the --no-install-recommends flag. This won't install the recommended dependencies.

  • 2
    You could probably just install gummi without texlive by adding the --no-install-recommends flag, or by building and installing the equivs package (Google "Debian vanilla texlive" for a description – daleif Jul 9 '18 at 18:22
  • @daleif Thanks. "--no-install-recommends" seems like a proper solution. – paulplusx Jul 10 '18 at 5:26
  • @daleif you may add the answer. I'll mark it correct. – paulplusx Jul 16 '18 at 7:09
  • No need just add it to your own answer for others to find – daleif Jul 16 '18 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.