I cannot, for the life of me, get biblatex's apa style to work. Other biblatex styles work fine, apa, however, does neither print a reference list, nor produce a citation at all (single output is key in boldprint). Warning "undefined references" is produced.

\usepackage[german, ngerman]{babel}
\usepackage[style=apa, backend=biber]{biblatex}


    Address = {Philadelphia},
    Author = {William Labov},
    Publisher = {University of Pennsylvania Press},
    Title = {Sociolinguistic Patterns},
    Year = {1972}}



Bla \cite{Labov1972}



I run the newest version available of all packages. Can someone help, please? Am I just overlooking the obvious?

  • Just checking, are you running bibtex or biber on the file? (You've specified backend=biber, which means you need to use it to sort the references, not bibtex.)
    – Alan Munn
    Feb 9, 2012 at 20:38
  • I used biber. As I said, it works fine for the other styles. I'm guessing it must be a problem with biblatex-apa.
    – die Anne.
    Feb 9, 2012 at 22:00
  • Your document works fine on my system (TeXLive 2011 on Mac). Have you deleted all the associated .aux and .bcf files etc.? If that doesn't change things can you add \listfiles to your document and add the console output to your question.
    – Alan Munn
    Feb 9, 2012 at 23:27
  • 2
    Having just updated my system I can now reproduce your problem.
    – Alan Munn
    Feb 10, 2012 at 2:04

2 Answers 2


This is a bug in biblatex 1.7 and the \RequireBiber[3] setting it appears. This was changed in biblatex-apa style 4.5. You can change the apa.bbx file to \RequireBiber[2] to fix it. I have released version 4.6 of the style with this setting and it should be in TL today.

  • Cool, looking forward to that.
    – die Anne.
    Feb 10, 2012 at 8:50
  • 1
    I recently upgraded MikTek 2.9's packages and now I get biblatex Error: Option 'sorting=apa' invalid. (when not including backend=biber). If I use the example by die Anne I get the same error she had even if I edit apa.bbx to contain \RequireBiber[2] or \RequireBiber[1], as well as if I just replace it by the current v4.6 apa.bbx file. This was with biblatex v1.7 and biber v.0.9.8 Feb 20, 2012 at 17:03
  • 1
    Yes, you have to use Biber with the style now because it needs a custom sorting specification not possible with bibtex.
    – PLK
    Feb 21, 2012 at 6:48
  • Just a side note: You can see the version of biblatex-apa distributed by MiKTeX here: miktex.org/packages/biblatex-apa
    – matth
    Feb 21, 2012 at 10:52
  • Version 4.6 - that is the latest version
    – PLK
    Feb 21, 2012 at 11:00

I could replicate the error on my TeXLive 2011 Mac installation after updating to current packages via TeX Live Utility (biblatex 1.7, biblatex-apa 4.4, biber 0.9.8).

A quick fix for me was a change to the apa.bbx file in line 29:

\RequireBiber[3] % Biber is strictly required now due to custom sorting


\RequireBiber[1] % Biber is strictly required now due to custom sorting

I couldn't determine whether this is indeed a veritable cause for the "Empty bibliography" error you describe or an artefact due to some underlying problems. However the solution could reliably be repeated after a clean reinstall of all affected packages.

  • Nice fix. My system hadn't been updated in for a couple of days.
    – Alan Munn
    Feb 10, 2012 at 2:03
  • Great. That did the trick.
    – die Anne.
    Feb 10, 2012 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.