1

I just tested Excalibur, an interactive, TeX aware spell checker, to correct typos of a TeX-file. However, when I was finished assessing the suggestions and attempted to save the file, a popup appeared:


An problem occurred with the file 'seq_0.tex'.

-50


The file that had been checked was called seq_0.tex;
I removed the '_' in case the programme couldn't handle that symbol, but the same error occurred. So I created a txt-file with the same content as seq_0.tex. Excalibur displayed the same error message, when I was trying to save the file after reviewing it. My document contains names of German mathematicians, including the symbol 'ß', which is not displayed correctly in the interface of Excalibur. But it would be embarrassing if it couldn't handle these symbols, cause there are German dictionary files for it.

Of course I googled, searched for help in the latest version of the excalibur manual I could find (4.0 from 2001), and looked for similar issues in forums. However, I couldn't identify the problem.

System details

  • Excalibur version: 4.0.7
    • LaTeX options: Use extended character set
  • operating system: Mac OS (10.13.6 Beta (17G54a)) (pls don't tell me to use a capable linux version instead :D)
  • Editor I created the TeX file with: TeXShop (4.01)
    • Encoding chosen: Unicode (UTF-8)
  • Editor I created the txt file with: iA Writer 5.0.3 (6214)

If I missed any crucial information or messed up something else, pls let me know :)

Best, TFT

PS: I attempted to label this post with 'excalibur', but lacked the 'reputation' to due so. If this label appears to be useful to someone who can edit my post, pls add it :)

  • I tried to provide a link to the manual, but I can't open the page and the url displayed by google doesn't work. sry for the splitting ... couldn't edit my first comment anymore... – TopologicalFieldTheory - TFT Jul 10 '18 at 20:16
  • 1
    Tested on Mac OS X 10.12 and it works. Are you sure about “10.13.6 Beta”? – egreg Jul 10 '18 at 20:43
  • yes I am pretty sure about that. I copied this information from the 'about this mac' display board. <br> Thanks for your comment! Did the saving work after you altered the content with excalibur ? Are symbols like 'ß' correctly displayed in the interface of Excalibur ? – TopologicalFieldTheory - TFT Jul 10 '18 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.