Will someone please help me to both configure Texmaker and use it so that I can use the backend=biber option with biblatex package. I am using MiKTeX 2.8 and Texmaker 3.1. Please do not simply tell me to read the manuals as I have spent most of the afternoon on them and the "working examples," rather than spending it on actually producing a paper.

I think what needs to be fixed is one or both of the BIBTEX command and my QUICKBUILD command in the configuration. What I have done is to put the biber.exe file into the bin directory in my LaTeX tree which is located in C:/Latex/MyLatex. I tried to set the BIBTEX command to "C:/Latex/MyLatex/bin/biber.exe" %.aux and then used the "Quick Build Wizard" to run PDFLATEX -> BIBTEX -> PDFLATEX. The minimum working example I'm attempting is posted below. It works using bibtex (and deleting backend=biber). I would really appreciate if one of you could provide me some direct guidance.

%%% Tex File






Some text is here.



%%% BIB file
   author = {H. Akaike},
   title = {Information theory and an extension of the maximum likelihood principle},
   editor = {B. N. Petrov and F. Csaki},
   booktitle = {2nd International Symposium on Information Theory},
   pages = {267-281},
   year = {1973},
   location = {Budapest: Akademiai Kiado} 

   author = {Akaike},
   title = {Factor analysis and AIC},
   journal = {Psychometrika},
   volume = {52},
   number = {3},
   pages = {317-332},
   year = {1987}

4 Answers 4


You should update to the newest version of MiKTeX, because it does already come with Biber included (by update I mean uninstall old version, install newest version, then run update manager). Biber will then be installed under

%ProgramFiles(x86)%\MiKTeX 2.9\miktex\bin\biber.exe

Then you only need to tell Texmaker to use biber % instead of bibtex %.aux (see answer by Mark S. Everitt), that is all. Below you can see how I configured Texmaker.

Click for full size
Click for full size

  • 3
    Just a remark: The environment variable %Programfiles(x86)% does exist only on the 64-bit-versions of Windows. If the OP has a 32-bit-variant, the variable is %Programfiles% (as usual in Windows the case doesn’t matter).
    – Speravir
    Feb 10, 2012 at 16:13
  • Thanks for the suggestions. I will update Miktex and try again.
    – Bob P
    Feb 16, 2012 at 16:51
  • I upgraded to Miktex 2.9 and now I can indeed just use biber % for the bibtex command. Now I've been trying to invoke the APA style (using the commented usepackage command immediately above the uncommented one in the code provided), and this is not working. The Log says that all style files were found. The warnings are that the references are undefined. It suggests re-running Biber. I changed my quickbuild command to be PDFlatex -> Bibtex -> Bibtex -> PDFlatex but to no avail. Do you have any further suggestions? I'd sure appreciate it.
    – Bob P
    Feb 16, 2012 at 18:54
  • First, congratulations for upgrading ;-) Running pdflatex -> biber -> pdflatex should be enough. Maybe there are problems with your Quickbuild command? Alternatively, could you try pressing F6, then F11, then F6 (F6 will run pdflatex, F11 will run biber) and see if that works?
    – matth
    Feb 16, 2012 at 20:38
  • That wasn't it. Again, the commands worked with \usepackage[backend=biber]{biblatex} but not with \usepackage[style=apa,sorting=nyt,backend=biber]{biblatex}
    – Bob P
    Feb 17, 2012 at 0:42

I think that your problem is likely to be the way you've configured Texmaker. I'm not using windows, but my tests predict that if you replace

"C:/Latex/MyLatex/bin/biber.exe" %.aux

in your preferences with

"C:/Latex/MyLatex/bin/biber.exe" %

then it should work. The reason is that Biber doesn't take an .aux file as its argument. It really operates on the .bcf file, so

"C:/Latex/MyLatex/bin/biber.exe" %.bcf

will also work.


just spent a day struggling with this too

I used the little browse icon to the side of the bib(la)tex field to find the biber program and it worked fine.

I also found that using LaTeX build option (i.e. not pdflatex,etc) for the first build then a bibtex build on the same .tex document then pdfLaTeX build worked well.

my bibliography file bib.bib looks like (using science directs export citation):

title = "Absorption of water vapour into lithium bromide-based solutions with additives using a simple stagnant pool absorber ",
journal = "International Journal of Refrigeration ",
volume = "22",
number = "3",
pages = "188 - 193",
year = "1999",
note = "",
issn = "0140-7007",
doi = "10.1016/S0140-7007(98)00061-9",
url = "http://www.sciencedirect.com/science/article/pii/S0140700798000619",
author = "Jin-Soo Kim and Huen Lee and Sun Il Yu",
keywords = "Absorption",
keywords = "Water",
keywords = "Lithium bromide",
keywords = "Absorption",
keywords = "Eau",
keywords = "Bromure de lithium "

and the .tex file looks like

\usepackage[backend=biber, style=authoryear]{biblatex}


Kim, Lee, and Yu 1999 ...

References Kim, Jin-Soo, Huen Lee, and Sun Il Yu (1999). \Absorption of water vapour into lithium bromide-based solutions with additives using a simple stagnant pool absorber". In: International Journal of Refrigeration 22.3, pp. 188{ 193. issn: 0140-7007. doi: 10.1016/S0140-7007(98)00061-9. url: http: //www.sciencedirect.com/science/article/pii/S0140700798000619.

I need to learn how to tidy up the references but I hope this helps get you started


My code stopped compiling, and so I used the instructions in the @matth answer above. Things still did not work, even when I downloaded OP's example and run it. The issue was that biber correctly found the .bib file but did not extract any entries from the .tex file. This resulted in the "bold letters". From this blog entry I learned that it may help to clear biber's cache (disclaimer: I am not an advanced user, and I am not sure how biber uses cache and what the consequences may be).

Running the command below in Terminal solved my issues.

rm -rf $(biber --cache)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .