I'm currently writing on my bachelor thesis, which we have a template from the university we are forced to use. Apparently the table of content is supposed to start with page 1, in my case it starts with page 3.

My Professor said, the lines



are supposed to tackle this issue, since the numbering is first set to roman. Then the table is generated and then the numbering is set back to arabic, thus reseting the counters. However it doesn't seem to work. Someone got any suggestions?

Here's the template im using:

\documentclass[a4paper, 11pt, twoside, openright, DIV15, BCOR15mm]{scrbook}
% Packages
% Hyperref-Optionen für PDF-Files
%% Verhindert Schusterjungen und Hurenkinder
\clubpenalty = 10000
\widowpenalty = 10000 \displaywidowpenalty = 10000
% Kein Einzug beim Paragraphenanfang
% Stil für das Literaturverzeichnis
% Tiefe für das Inhaltsverzeichnis
% listings-Package
%   Hintergrundfarbe von Quellcode
\lstloadlanguages{[ANSI]C++, Java}
\lstset{basicstyle = \ttfamily \small}
\lstset{extendedchars=true} \lstset{showstringspaces = false}
% ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
% Kopfzeile
\renewcommand{\sectionmark}[1]{\markright{\thesection\ #1}}
\fancyhf{} \fancyhead[L, RO]{\small \thepage}
\fancyhead[LO]{\small \nouppercase  \leftmark}
\fancyhead[RE]{\small \nouppercase \rightmark}
    \fancyhead{} %
    \renewcommand{\headrulewidth}{0pt} %
% Abstände zwischen Caption und Bild/Tabelle
\setlength\abovecaptionskip          {0.4em}
\setlength\belowcaptionskip          {0.2em}

% Anteil der Grafiken höher auf jeder Seite!

\renewcommand{\captionlabelfont}{\small \bfseries}

% Kein Auseinanderziehen gegen das Seitenende
% Beginn Dokument
% \includepdf[pages=-]{content/deckblatt.pdf}

% Inhaltsverzeichnis
% Schalten Sie auf kleine römische Zahlen als Nummerierung um -- sonst
% fängt im Inhaltsverzeichnis das erste Kapitel auf Seite 6 an; Seite 1 wäre besser, oder?
% Jetzt schalten wir wieder auf arabische Zahlen, und die Zähler werden zurückgesetzt

% Input aller Teildateien

% Literatur

% Anhang


  • 2
    You have to use a \cleardoubleoddpage immediately before \pagenumbering: \cleardoublepage\pagenumbering{roman}\tableofcontents should work. But your template is terrible ... As already mentioned in comments to tex.stackexchange.com/q/437054/43317 hanser.sty is outdated. There are outdated class options. hyperref is loaded to early, do not change \parskip manuelly, ... – esdd Jul 13 '18 at 7:31

The solution is to use \clearpage or \cleardoublepage before switching the numbering style.


Results in:

enter image description here

Omitting the new page means that the pagenumbering will already be set to arabic underneath the table of contents, which is still on the same page, so it overwrites the other pagenumbering.

As shown here:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.