1

I want to use biblatex-apa with biber-backend to create a bibliography. I use the shortauthor-tag, so that the full names of the organizations only appear once, and only abbreviations afterwards. This seems not to work, when I fist cite both publications at the same time in a multiple citation, as shown in the MWE below.

I am using biber v2.11 and biblatex v3.11 (installed via MiKTeX 2.9.6730 on Win10).

\documentclass[12pt,a4paper]{scrartcl}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc} 
\usepackage{lmodern}
\usepackage[ngerman]{babel}
\usepackage[backend=biber,style=apa,sortlocale=de_DE]{biblatex}

\DeclareLanguageMapping{ngerman}{ngerman-apa}

\setlength\bibitemsep{1.5\itemsep}
\addbibresource{literatur.bib}

\begin{document}
\parencite{BMG2018, BLS2011} \\

\parencite{BLS2011} \\

\parencite{BMG2018} \\

\parencite{BLS2011} 

\printbibliography
\end{document}

Here is my .bib-File:

@online{BMG2018,
author = {{Bundesministerium für Gesundheit}},
shortauthor = {BMG},
title = {Gesund bleiben: Prävention und Gesundheitsförderung.},
date = {2018},
}

@booklet{BLS2011,
author = {{Bayerischer Landes-Sportverband e. V.}},
shortauthor = {BLS},
title = {Gesundheitssport im Verein},
date = {2011},
}

The following is what I get from this: enter image description here

As you can see, the second time I cite the "Bayrischer Landes-Sportbund" (BLS), the citation looks completely different with the abbreviation not even in square brackets.

This is what I would expect to see: enter image description here

It works, when I do the citations seperately the first time, e.g.

\parencite{BMG2018} \\
\parencite{BLS2011} \\

\parencite{BLS2011} \\

\parencite{BMG2018} \\

\parencite{BLS2011} 

, but I need the initial double-citation.

Question: Is this behaviour intended? If so, what am I doing wrong? If not, what is a possible workaround?

2

This appears to be the same bug as https://github.com/plk/biblatex-apa/issues/24

The workaround

\DeclareCiteCommand{\parencite}[\mkbibparens]
  {\usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{cite}%
   \usebibmacro{cite:post}}
  {}
  {\usebibmacro{postnote}}

works here as well. But you may want to fix all cite commands so that you also need

\DeclareCiteCommand*{\parencite}[\mkbibparens]
  {\usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{citeyear}%
   \usebibmacro{cite:post}}
  {}
  {\usebibmacro{postnote}}

\DeclareCiteCommand{\nptextcite}
  {\usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \global\booltrue{cbx:np}%
   \usebibmacro{textcite}%
   \global\boolfalse{cbx:np}%
   \usebibmacro{cite:post}}%
  {}
  {\iffieldundef{postnote}
     {}
     {\printdelim{nameyeardelim}%
      \printfield{postnote}}}

% doubtful if cite:post should be called at all
\DeclareCiteCommand{\fullcite}
  {\usebibmacro{prenote}}
  {\usedriver
    {\DeclareNameAlias{sortname}{default}%
      \global\boolfalse{bbx:parens}%
      \global\boolfalse{bbx:volseen}%
      \global\boolfalse{bbx:titleinauthpos}%
      \global\boolfalse{bbx:editorinauthpos}%
      \global\boolfalse{bbx:in}%
      \global\let\blx@related@loop\@empty}
    {\thefield{entrytype}}%
   \usebibmacro{cite:post}}
  {\multicitedelim}
  {\usebibmacro{postnote}}

% doubtful if cite:post should be called at all
\DeclareCiteCommand{\fullcitebib}
  {\list{}
   {\setlength{\leftmargin}{\bibhang}%
     \setlength{\itemindent}{-\leftmargin}%
     \setlength{\itemsep}{\bibitemsep}%
     \setlength{\parsep}{\bibparsep}}\item}
  {\usedriver
    {\DeclareNameAlias{sortname}{default}%
      \global\boolfalse{bbx:parens}%
      \global\boolfalse{bbx:volseen}%
      \global\boolfalse{bbx:titleinauthpos}%
      \global\boolfalse{bbx:editorinauthpos}%
      \global\boolfalse{bbx:in}}
    {\thefield{entrytype}}\finentry
   \usebibmacro{cite:post}}
  {\item}
  {\endlist}

\DeclareCiteCommand{\cite}
  {\usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{cite}%
   \usebibmacro{cite:post}}
  {}
  {\usebibmacro{postnote}}

\DeclareCiteCommand*{\cite}
  {\usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{citeyear}%
   \usebibmacro{cite:post}}
  {}
  {\usebibmacro{postnote}}

\DeclareCiteCommand{\footcite}[\mkbibfootnote]
  {\bibsentence
   \usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{cite}%
   \usebibmacro{cite:post}}
  {}
  {\usebibmacro{postnote}}

\DeclareCiteCommand{\textcite}
  {\usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{textcite}%
   \usebibmacro{cite:post}}
  {}
  {\usebibmacro{textcite:postnote}}

\DeclareCiteCommand{\citeauthor}
  {\usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{cite:author}%
   \usebibmacro{cite:post}}
  {}
  {\usebibmacro{postnote}}

You will then get

enter image description here

  • Thank you for the nice answer. Do you have any suggestion how I can fix the natbib-equivalent commands \citep, \citet etc. when using biblatex with the natbib=true option? – Pidrittel Jul 13 '18 at 12:55
  • 1
    @Pidrittel The natbib commands should be automatically fixed if you fix the standard commands. Does that not work for you? – moewe Jul 13 '18 at 13:06
  • No, it works. I did not even try it before I asked, sorry. Thank you very much again. :) – Pidrittel Jul 13 '18 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.