I have been using a poster template (please, click here to see it) that I found on overleaf based on baposter.cls (you can find it here).

In such environment, \dot{x} produces a bar below the letter, while \tilde{x} produces a sort of strikethrough.

For several hours, I have been trying to determine how to solve the problem by using the function \DeclareSymbolFont as suggested in two previous questions (question 1, question 2) to define the correct accent command but, lacking proper programming skills, I have had no success.

Does anyone know a way to fix this issue? Thank you for all your help!

  • Welcome to TeX.SE. Do \dot{x} and \tilde{x} occur in math mode or in text mode? – Mico Jul 16 '18 at 1:17
  • 2
    Welcome to TeX.SX! Please post a minimal working example to show us what you have tried. Giving external links is not very helpful because if they disappear the future then your post will be useless to people who look at your question later. Many people do not look at external links so using them makes it less likely that some one will answer your question. A MWE should be a the smallest amount of code necessary that compiles and demonstrates your problem. – user30471 Jul 16 '18 at 2:02

The poster template is using Calibri for setting up text, and Latin Modern for math (Latin Modern Sans, to be more specific). I recommend using a Helvetica clone text to match Latin Modern Sans math for your poster. Note that the original font settings are not exactly matched anyway.

Just add

\usepackage{amsmath} % math <-- Remove amssymb!!

to the preamble, and your problem vanishes. Note that you must prevent amssymb from being loaded, as newtxmath already provides its own set of symbols. The output is as follows:

Correct dot and tilde

I suspect that the problem comes from wrong mapping of glyphs. But since the font declaration is hidden on overleaf, I cannot be sure.

  • As you said, it solved the problem! You have all my gratitude!!!!!!!!!! – another_newbie Jul 16 '18 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.