3

I have implemented the following style for my footnotes in memoir

\documentclass{memoir}

\usepackage{lipsum}
\usepackage{calc}

\setlength\footparindent{1.2\parindent}

\newlength{\foothelp}
\newlength{\foothelpextra}
\footmarkstyle{%
\setlength{\foothelp}{\footparindent}%
\setlength{\foothelpextra}{\widthof{\textsuperscript{#1}}}%
\addtolength{\foothelp}{-\foothelpextra}%
\textsuperscript{#1}\hspace{\foothelp}%
}


\begin{document}
\lipsum[1]\footnote{\lipsum[1]

\lipsum[1]}

\setcounter{footnote}{999}\footnote{\lipsum[1]

\lipsum[1]}
\end{document}

But if I change the font size I need to manually adjust the \footparindent. Is there a better way of implementing this style? Moreover, is it possible for the indent in the footnotes to match the indent in the body text? This style is very much like in this question:

Adjust footnote indentation in memoir

The difference is that the footnote mark should be flushleft.

enter image description here

Edit: Added a picture displaying the style. As can be seen all the indents doesn't quite match up.

2
  • I can't get your MWE to work. I think you have a problem with your code for \footmarkstyle. Jul 20, 2018 at 18:31
  • @Peter Wilson That's weird. It compiles with no problems on my setup.
    – M0erck
    Jul 20, 2018 at 20:53

2 Answers 2

2

Is this what you are looking for?

\setlength{\footmarkwidth} {0em}
\setlength{\footmarksep}   {0em}
\footmarkstyle{\makebox[\footparindent][l]{\textsuperscript{#1}}}

Set \footparindent to \parindent proper to have them line up.

In this MWE the \XXX is just an easy way to show the alignment, it is designed to not disturb.

\documentclass{memoir}

\usepackage{lipsum}

\setlength\footparindent   {\parindent}
\setlength{\footmarkwidth} {0em}
\setlength{\footmarksep}   {0em}
\footmarkstyle{\makebox[\footparindent][l]{\textsuperscript{#1}}}


\newcommand\XXX{\llap{\smash{\rule[-\paperheight]{0.1pt}{2\paperheight}}}}

\begin{document}
\lipsum[1]\footnote{\lipsum[1]

\lipsum[1]}

\setcounter{footnote}{999}\footnote{\XXX\lipsum[1]

\lipsum[1]}
\end{document}
2
  • 2
    Ah, you beat me by 40 seconds. LOL Jul 20, 2018 at 22:45
  • Setting \footmarkwidth and \footmarksep equal to 0 solved the problem. But the \makebox solution is much more elegant than mine and in particular doesn't require additional packages. The solutions are identical, so I don't know what I should do in this situation?
    – M0erck
    Jul 21, 2018 at 6:54
1

Like this?

\documentclass{memoir}

\usepackage{lipsum}
%\usepackage{calc}

\footmarkstyle{%
  \makebox[\parindent][l]{\textsuperscript{#1}}%
}
\setlength{\footmarkwidth}{0pt}
\setlength{\footmarksep}  {0pt}
\setlength{\footparindent}{\parindent}

\begin{document}
\lipsum[1]\footnote{\lipsum[1]\lipsum[1]}

\setcounter{footnote}{999}\footnote{\lipsum[1]\lipsum[1]}
\end{document}

footnote

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.