0

I wanted to change the default font to Utopia, I saw how to do it here, so I copy&pasted the lines from the Usage chapter of that link:

\usepackage{fourier}
\usepackage[T1]{fontenc}

And nothing works...I just get the following error:

Sorry, but miktex-makepk did not succeed for the following reason: PK font futb8r could not be created.

In the log file this is written:

2018-07-21 17:11:40,471+0200 INFO  miktex-makemf - starting with command line: miktex-makemf.exe --verbose futb8r
2018-07-21 17:11:40,471+0200 FATAL miktex-makemf - The futb8r source file could not be found.

I'm using TeXstudio 2.12.10 on Windows 10.

\documentclass[]{report}
%Import packages and settings
\usepackage[utf8]{inputenc}
\usepackage{fourier}
\usepackage[T1]{fontenc}
\usepackage{color}
%\input{pkgs}
%Import variables
%\input{variables}

% ************ DOCUMENT BEGINS

\begin{document}
%   \include{titlepage}            
    %   Abbildungen
%   \addcontentsline{toc}{chapter}{\listfigurename}
%   \listoffigures  
    %   Tabellen 
%   \addcontentsline{toc}{chapter}{\listtablename}
%   \listoftables
    %   Abkürzungen
%   \makenomenclature
%   \printnomenclature[9em]
%   \include{chapters/abstract}
    \tableofcontents
    \include{chapters/introduction}
    \include{chapters/methods}
    \include{chapters/overview}
    \include{chapters/findings}
    \include{chapters/conclusion}
    % Set bib style and add bib
    \bibliographystyle{abbrv}
    \bibliography{lit}
\end{document}
9
  • Is package fourier installed?
    – Bernard
    Jul 21, 2018 at 15:39
  • Is this (→ tex.stackexchange.com/questions/209430/…) similar to your case?
    – DG'
    Jul 21, 2018 at 15:39
  • @DG' I'm not really in a "multiuser environment" as far as I know, so I guess no
    – Cold_Class
    Jul 21, 2018 at 15:41
  • @Bernard can't TeXStudio install everything that's missing automatically? It did install a lot of pkgs when I first compiled this, so I expected it to have everything loaded. I don't know if it's installed, where do I have to check? My Windows10 font folder?
    – Cold_Class
    Jul 21, 2018 at 15:42
  • To check whether it is installed, load MiKTeX console/ Package manager, and type fourier in the editing window. If fourier is installed, this means the compiler doesn't find the type1 version of the font; i.e. dvips.map and friends were not updated when the font was installed. Refresh Fontmap files fromMiKTeX console (Tasks menu).
    – Bernard
    Jul 21, 2018 at 15:43

1 Answer 1

2

Here's how to refresh fontmap files from within MiKTeX Console (depending on your installation, you may have to do it as Administrator or as User):

enter image description here

4
  • Thanks, so they first problem I realized I had: MiKTeX Console was not in my StartMenu, only Package Manager and Settings - so I reinstalled it completely - and after I refreshed the font map files as USER it finally worked! :)
    – Cold_Class
    Jul 21, 2018 at 18:33
  • Did you have an old installation?
    – Bernard
    Jul 21, 2018 at 18:35
  • I don't think so, it was something with 2.9 as well, but I must have messed some stuff up - when installing it the first time there was an error because TeXStudio was still open, after I closed everything it worked. I guess maybe I had and ignored that same error during my first installation and since then never had that Console and maybe other things were missing due to it too
    – Cold_Class
    Jul 21, 2018 at 18:40
  • 1
    MiKTeX 2.9 was out in october 2010, whereas MiKTeX Console, such as it is now, was out only a few months ago.
    – Bernard
    Jul 21, 2018 at 18:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .