5

I use the beamer package for presentations and often complement it with animate (together with tikz) and multimedia. animate creates embedded JavaScript, playable with acroread. multimedia embeds videos (avi, mp4, ...) playable via okular via some video player available to it (e.g. mplayer). Unfortunately I have not found a PDF player capable of displaying both JavaScript and videos under Ubuntu. How can I circumvent this issue? I have an upcoming presentation where I would like to be able to play both types of content.

  • 2
    Perhaps this old thread may still be of some help. – Mike Jul 24 '18 at 22:18
  • 1
    The problem is that currently there is no actively developed PDF viewer for Linux with a JavaScript engine. – AlexG Aug 6 '18 at 11:54
  • @AlexG See my (unsatisfying) workaround. – Miguel Aug 15 '18 at 16:41
3

Well, after getting very frustrated about this I finally managed to get both animate and media9 content (using the embedded VPlayer.swf, see How to include multimedia files in beamer) to play under Ubuntu 18.04 by installing the latest Windows 10 Adobe Reader via wine. To play videos, one also needs to install the Firefox Flash Player plugin via wine.

This is a disappointing solution but it will have to do until someone developing native Linux PDF viewers decides to incorporate JS functionality.


Update 27/01/2020:

I recently had to make a fresh install on a new machine, so I took the chance to gather the steps. On Ubuntu 18.04.03 this works:

sudo apt install wine-stable winetricks winbind
winetricks mspatcha
# Important to get this version of AcrobatDC, newer versions didn't work for me
wget ftp://ftp.adobe.com/pub/adobe/reader/win/AcrobatDC/1800920044/AcroRdrDC1800920044_en_US.exe
wine AcroRdrDC1800920044_en_US.exe
wget https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player.exe
wine install_flash_player.exe
  • Thank you very much for your contribution. I have tried the same a couple of times without success on my Linux PC running Gentoo Linux. Could you please extend your answer, including a step-by-step instruction for the installation procedure and perhaps a list of additional packages, libraries etc.? – AlexG Aug 16 '18 at 6:50
  • 1
    @AlexG It could be that you need the latest Ubuntu. I'll try to extend the answer when I have the time. Having to embed the videos is still a bother for large ones. I have even tried a local webserver approach which works, but the loading time is quite long, so not workable for a live presentation in front of an audience. Thanks for developing the media9 package by the way. – Miguel Aug 16 '18 at 10:00
  • @AlexG See my edit, hopefully this works out for you – Miguel Jan 27 at 11:16
  • Thanks a lot for adding instructions! – AlexG Jan 27 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.